summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-03-19 11:06:48 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-03-19 13:17:13 -0400
commitae08cbfe1101c452bcd98726bcfbafbc1a5e5b9f (patch)
tree076b4f8b4c49c1880e02ac3bf3c47aec800fd38a
parent73807b49c495105b33b83deec1402080a78b09b0 (diff)
downloadpython-systemd-ae08cbfe1101c452bcd98726bcfbafbc1a5e5b9f.tar.gz
Makefile: remove unneeded -I/usr/include from flags
gcc warns about an include directive that shadows the system include directory at high verbosity levels. Let's filter it out (pkgconfig implements that) to reduce noise and also to make the command line shorter.
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 290ac8a..e4019d0 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,7 @@ SED = sed
SPHINX_BUILD = sphinx-build
ETAGS = etags
INCLUDE_DIR := $(shell pkg-config --variable=includedir libsystemd)
+INCLUDE_FLAGS := $(shell pkg-config --cflags libsystemd)
VERSION := $(shell $(PYTHON) setup.py --version)
TESTFLAGS = -v
@@ -31,7 +32,7 @@ update-constants: $(INCLUDE_DIR)/systemd/sd-messages.h
mv docs/id128.rst{.tmp,}
build:
- $(PYTHON) setup.py build_ext $(if $(INCLUDE_DIR),-I$(INCLUDE_DIR))
+ $(PYTHON) setup.py build_ext $(INCLUDE_FLAGS)
$(PYTHON) setup.py build
install: