summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDominik Prien <dprien@users.noreply.github.com>2019-07-01 19:43:34 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2020-11-11 22:38:04 +0100
commitd08f8dd0f4607a72f1d5497467a2f0cf5a8ee5d4 (patch)
tree9583a450b432a4a38046e24d613d7e19b89dddfc /Makefile
parentced5a2098691f0e5199e98974ead7cb42d7e69c1 (diff)
downloadpython-systemd-d08f8dd0f4607a72f1d5497467a2f0cf5a8ee5d4.tar.gz
make: Move -std=99 to setup.py
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 6d6f749..b7070df 100644
--- a/Makefile
+++ b/Makefile
@@ -6,8 +6,6 @@ INCLUDE_FLAGS := $(shell pkg-config --cflags libsystemd)
VERSION := $(shell $(PYTHON) setup.py --version)
TESTFLAGS = -v
-CFLAGS = -std=c99
-
define buildscript
import sys,sysconfig
print("build/lib.{}-{}.{}".format(sysconfig.get_platform(), *sys.version_info[:2]))
@@ -32,7 +30,7 @@ update-constants: update-constants.py $(INCLUDE_DIR)/systemd/sd-messages.h
mv docs/id128.rst{.tmp,}
build:
- CFLAGS=$(CFLAGS) $(PYTHON) setup.py build_ext $(INCLUDE_FLAGS)
+ $(PYTHON) setup.py build_ext $(INCLUDE_FLAGS)
$(PYTHON) setup.py build
install: