summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-07-05 14:39:14 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-07-05 15:10:30 -0400
commit31baccc855b48adde5173a31037bb1b82c42f7aa (patch)
treef932694ba82c76714400b09d08e7ebea435c1c51 /setup.py
parent022c9b5be4a1edf77bf73566a89ce41397f72147 (diff)
downloadpython-systemd-31baccc855b48adde5173a31037bb1b82c42f7aa.tar.gz
build-sys: update setup.py to build everything
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py42
1 files changed, 36 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index bd4402f..5ff205e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,13 +1,43 @@
from distutils.core import setup, Extension
-cjournal = Extension('systemd/_journal',
- libraries = ['systemd-journal'],
- sources = ['systemd/_journal.c'])
+version = '221'
+defines = [('PACKAGE_VERSION', '"{}"'.format(version))]
+_journal = Extension('systemd/_journal',
+ define_macros = defines,
+ libraries = ['systemd'],
+ sources = ['systemd/_journal.c',
+ 'systemd/pyutil.c'])
+_reader = Extension('systemd/_reader',
+ define_macros = defines,
+ libraries = ['systemd'],
+ sources = ['systemd/_reader.c',
+ 'systemd/pyutil.c',
+ 'systemd/strv.c'])
+_daemon = Extension('systemd/_daemon',
+ define_macros = defines,
+ libraries = ['systemd'],
+ sources = ['systemd/_daemon.c',
+ 'systemd/pyutil.c'])
+id128 = Extension('systemd/id128',
+ define_macros = defines,
+ libraries = ['systemd'],
+ sources = ['systemd/id128.c',
+ 'systemd/pyutil.c'])
+login = Extension('systemd/login',
+ define_macros = defines,
+ libraries = ['systemd'],
+ sources = ['systemd/login.c',
+ 'systemd/pyutil.c',
+ 'systemd/strv.c'])
setup (name = 'systemd',
- version = '0.1',
+ version = version,
description = 'Native interface to the facilities of systemd',
author_email = 'david@davidstrauss.net',
url = 'https://github.com/systemd/python-systemd',
- py_modules = ['systemd.journal'],
- ext_modules = [cjournal])
+ py_modules = ['systemd.journal', 'systemd.daemon'],
+ ext_modules = [_journal,
+ _reader,
+ _daemon,
+ id128,
+ login])