summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 8c3b902..e17e1bd 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@ SPHINX_BUILD = sphinx-build
ETAGS = etags
INCLUDE_DIR = /usr/include/
VERSION := $(shell $(PYTHON) setup.py --version)
+TESTFLAGS = -v
define buildscript
import sys,sysconfig
@@ -34,6 +35,9 @@ sphinx-%: build
PYTHONPATH=$(builddir) $(SPHINX_BUILD) -b $* $(SPHINXOPTS) docs build/docs
@echo Output has been generated in build/docs
+check: build
+ $(PYTHON) -m py.test $(builddir) docs $(TESTFLAGS)
+
TAGS: $(shell git ls-files systemd/*.[ch])
$(ETAGS) $+