summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2011-11-09 15:49:52 +0000
committerAndrew Stitcher <astitcher@apache.org>2011-11-09 15:49:52 +0000
commit9f0784cab45c5e832c945a067926440d3f4f3fc5 (patch)
tree91ddbe39c90c7dcd364318d43088ab1624779abc
parent049fb4586b172532be49c79b4e56f746cd5954a8 (diff)
downloadqpid-python-9f0784cab45c5e832c945a067926440d3f4f3fc5.tar.gz
QPID-3586: Changes for QPID-3464 break cmake build in tar.gz distribution
- The previous fix for this problem broke the autotools build, so remove the StoreStatus cluster test again from the autotools build. git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/0.14@1199809 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/tests/cluster.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/qpid/cpp/src/tests/cluster.mk b/qpid/cpp/src/tests/cluster.mk
index c4216cbd3d..aa22d0e7c4 100644
--- a/qpid/cpp/src/tests/cluster.mk
+++ b/qpid/cpp/src/tests/cluster.mk
@@ -91,8 +91,11 @@ cluster_test_SOURCES = \
ForkedBroker.cpp \
PartialFailure.cpp \
ClusterFailover.cpp \
- InitialStatusMap.cpp \
- StoreStatus.cpp
+ InitialStatusMap.cpp
+
+# Moved this file here from cluster_test_SOURCES as it breaks the autotools build, but not the cmake
+# build and so we need to make sure it is present in the tarball
+EXTRA_DIST += StoreStatus.cpp
cluster_test_LDADD=$(lib_client) $(lib_broker) ../cluster.la -lboost_unit_test_framework