summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2009-05-01 21:48:18 +0000
committerStephen D. Huston <shuston@apache.org>2009-05-01 21:48:18 +0000
commitf5287cdd92c4f32a2baefe06615729fea92bebe1 (patch)
tree1ce56a7c57aa988366b7b8af28d0418f4ceca900
parent329c10339c5b506393a437518cd08fbba4307bcd (diff)
downloadqpid-python-f5287cdd92c4f32a2baefe06615729fea92bebe1.tar.gz
Add Visual Studio sln/vcproj files to EXTRA_DIST to include them in releases; fixes QPID-1836
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/0.5-release@770832 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/examples/Makefile.am2
-rw-r--r--qpid/cpp/examples/direct/Makefile.am6
-rw-r--r--qpid/cpp/examples/failover/Makefile.am5
-rw-r--r--qpid/cpp/examples/fanout/Makefile.am9
-rw-r--r--qpid/cpp/examples/pub-sub/Makefile.am9
-rw-r--r--qpid/cpp/examples/qmf-console/Makefile.am5
-rw-r--r--qpid/cpp/examples/request-response/Makefile.am9
-rw-r--r--qpid/cpp/examples/tradedemo/Makefile.am8
-rw-r--r--qpid/cpp/src/tests/Makefile.am19
9 files changed, 46 insertions, 26 deletions
diff --git a/qpid/cpp/examples/Makefile.am b/qpid/cpp/examples/Makefile.am
index f23f3ee9e0..90b397aa8a 100644
--- a/qpid/cpp/examples/Makefile.am
+++ b/qpid/cpp/examples/Makefile.am
@@ -37,7 +37,7 @@ $(MAKEDIST): Makefile
examplesdir=$(pkgdatadir)/examples
dist_examples_DATA = README $(MAKEDIST)
-EXTRA_DIST = README.verify verify verify_all
+EXTRA_DIST = README.verify verify verify_all examples.sln
# For older versions of automake
abs_top_srcdir = @abs_top_srcdir@
diff --git a/qpid/cpp/examples/direct/Makefile.am b/qpid/cpp/examples/direct/Makefile.am
index 8f220d1b7e..d817c0b85c 100644
--- a/qpid/cpp/examples/direct/Makefile.am
+++ b/qpid/cpp/examples/direct/Makefile.am
@@ -44,5 +44,7 @@ EXTRA_DIST= \
verify_cpp_python \
verify_cpp_python.in \
verify_python_cpp \
- verify_python_cpp.in
-
+ verify_python_cpp.in \
+ direct_declare_queues.vcproj \
+ direct_direct_producer.vcproj \
+ direct_listener.vcproj
diff --git a/qpid/cpp/examples/failover/Makefile.am b/qpid/cpp/examples/failover/Makefile.am
index 67d9eb4b95..eaa2d2d1c6 100644
--- a/qpid/cpp/examples/failover/Makefile.am
+++ b/qpid/cpp/examples/failover/Makefile.am
@@ -39,3 +39,8 @@ examples_DATA= \
$(MAKEDIST)
# FIXME aconway 2008-10-10: add verify scripts.
+
+EXTRA_DIST= \
+ failover_declare_queues.vcproj \
+ failover_replaying_sender.vcproj \
+ failover_resuming_receiver.vcproj
diff --git a/qpid/cpp/examples/fanout/Makefile.am b/qpid/cpp/examples/fanout/Makefile.am
index 395fcec9aa..62ebef01e1 100644
--- a/qpid/cpp/examples/fanout/Makefile.am
+++ b/qpid/cpp/examples/fanout/Makefile.am
@@ -40,9 +40,6 @@ EXTRA_DIST= \
verify_cpp_python \
verify_cpp_python.in \
verify_python_cpp \
- verify_python_cpp.in
-
-
-
-
-
+ verify_python_cpp.in \
+ fanout_fanout_producer.vcproj \
+ fanout_listener.vcproj
diff --git a/qpid/cpp/examples/pub-sub/Makefile.am b/qpid/cpp/examples/pub-sub/Makefile.am
index 1d52daf638..e0d489e52e 100644
--- a/qpid/cpp/examples/pub-sub/Makefile.am
+++ b/qpid/cpp/examples/pub-sub/Makefile.am
@@ -41,9 +41,6 @@ EXTRA_DIST= \
verify_cpp_python \
verify_cpp_python.in \
verify_python_cpp \
- verify_python_cpp.in
-
-
-
-
-
+ verify_python_cpp.in \
+ pub_sub_topic_listener.vcproj \
+ pub_sub_topic_publisher.vcproj
diff --git a/qpid/cpp/examples/qmf-console/Makefile.am b/qpid/cpp/examples/qmf-console/Makefile.am
index 04a92c214e..320883e528 100644
--- a/qpid/cpp/examples/qmf-console/Makefile.am
+++ b/qpid/cpp/examples/qmf-console/Makefile.am
@@ -43,3 +43,8 @@ examples_DATA= \
queuestats.cpp \
$(MAKEDIST)
+EXTRA_DIST= \
+ qmf_console_console.vcproj \
+ qmf_console_ping.vcproj \
+ qmf_console_printevents.vcproj \
+ qmf_console_queuestats.vcproj
diff --git a/qpid/cpp/examples/request-response/Makefile.am b/qpid/cpp/examples/request-response/Makefile.am
index d7e7d692de..80f855f6e5 100644
--- a/qpid/cpp/examples/request-response/Makefile.am
+++ b/qpid/cpp/examples/request-response/Makefile.am
@@ -41,9 +41,6 @@ EXTRA_DIST= \
verify_cpp_python \
verify_cpp_python.in \
verify_python_cpp \
- verify_python_cpp.in
-
-
-
-
-
+ verify_python_cpp.in \
+ request_response_client.vcproj \
+ request_response_server.vcproj
diff --git a/qpid/cpp/examples/tradedemo/Makefile.am b/qpid/cpp/examples/tradedemo/Makefile.am
index a3c7fabd65..c662ec0b8c 100644
--- a/qpid/cpp/examples/tradedemo/Makefile.am
+++ b/qpid/cpp/examples/tradedemo/Makefile.am
@@ -39,7 +39,7 @@ examples_DATA= \
declare_queues.cpp \
$(MAKEDIST)
-
-
-
-
+EXTRA_DIST= \
+ tradedemo_declare_queues.vcproj \
+ tradedemo_topic_listener.vcproj \
+ tradedemo_topic_publisher.vcproj
diff --git a/qpid/cpp/src/tests/Makefile.am b/qpid/cpp/src/tests/Makefile.am
index 9a81ef18b3..b6497c7a86 100644
--- a/qpid/cpp/src/tests/Makefile.am
+++ b/qpid/cpp/src/tests/Makefile.am
@@ -261,7 +261,24 @@ LONG_TESTS+=start_broker fanout_perftest shared_perftest multiq_perftest topic_p
reliable_replication_test federated_cluster_test_with_node_failure
EXTRA_DIST+=fanout_perftest shared_perftest multiq_perftest topic_perftest run_failover_soak reliable_replication_test \
- federated_cluster_test_with_node_failure
+ federated_cluster_test_with_node_failure \
+ tests.sln \
+ client_test.vcproj \
+ consume.vcproj \
+ echotest.vcproj \
+ header_test.vcproj \
+ latencytest.vcproj \
+ perftest.vcproj \
+ publish.vcproj \
+ receiver.vcproj \
+ sender.vcproj \
+ shlibtest.vcproj \
+ topic_listener.vcproj \
+ topic_publisher.vcproj \
+ txjob.vcproj \
+ txshift.vcproj \
+ txtest.vcproj \
+ unit_test.vcproj
check-long:
$(MAKE) check TESTS="$(LONG_TESTS)" VALGRIND=