summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2010-03-25 00:02:56 +0000
committerStephen D. Huston <shuston@apache.org>2010-03-25 00:02:56 +0000
commit98b03f42fdd31c7560f970fc8d58e2309696dcc5 (patch)
tree2fa0e6bdf419cbcd30f4a26afdaa3670382e123d
parent8b83b8a31d49c0cf5322bcb234c84d71366e4e09 (diff)
downloadqpid-python-98b03f42fdd31c7560f970fc8d58e2309696dcc5.tar.gz
Add missing qpidxarm.dll and plug-ins to installer; resolves QPID-2467.
Fix multi-platform installer build, legal files placement, install notes doc, and other miscellaneous nits in the installer. git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/0.6-release-windows-installer@927233 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/CMakeLists.txt15
-rw-r--r--qpid/cpp/src/CMakeLists.txt3
-rw-r--r--qpid/packaging/windows/INSTALL_NOTES.html62
-rw-r--r--qpid/packaging/windows/build_installer.bat7
-rw-r--r--qpid/packaging/windows/installer.proj8
-rw-r--r--qpid/packaging/windows/qpidc.wxs40
6 files changed, 99 insertions, 36 deletions
diff --git a/qpid/cpp/CMakeLists.txt b/qpid/cpp/CMakeLists.txt
index 272d007c4a..32563c3bac 100644
--- a/qpid/cpp/CMakeLists.txt
+++ b/qpid/cpp/CMakeLists.txt
@@ -55,16 +55,6 @@ if (WIN32)
DESTINATION ${QPID_INSTALL_EXAMPLESDIR}
COMPONENT ${QPID_COMPONENT_EXAMPLES}
PATTERN ".svn" EXCLUDE)
-
-set (CPACK_NSIS_EXTRA_INSTALL_COMMANDS "
- ExecWait 'gacutil -I \\\"$INSTDIR\\\\${QPID_INSTALL_LIBDIR}\\\\Apache.Qpid.Channel.dll\\\"'
- ExecWait 'gacutil -I \\\"$INSTDIR\\\\${QPID_INSTALL_LIBDIR}\\\\Apache.Qpid.Interop.dll\\\"'
- ")
-set (CPACK_NSIS_EXTRA_UNINSTALL_COMMANDS "
- ExecWait 'gacutil /u \\\"Apache.Qpid.Channel\\\"'
- ExecWait 'gacutil /u \\\"Apache.Qpid.Interop\\\"'
- ")
-
endif (WIN32)
set (QPIDC_CONF_FILE ${QPID_INSTALL_CONFDIR}/qpidc.conf CACHE STRING
@@ -72,9 +62,8 @@ set (QPIDC_CONF_FILE ${QPID_INSTALL_CONFDIR}/qpidc.conf CACHE STRING
set (QPIDD_CONF_FILE ${QPID_INSTALL_CONFDIR}/qpidd.conf CACHE STRING
"Name of the Qpid broker configuration file")
-install(FILES LICENSE NOTICE README SSL RELEASE_NOTES DESIGN
- xml/cluster.xml INSTALL-WINDOWS
- DESTINATION ${QPID_INSTALL_DATADIR})
+install(FILES LICENSE NOTICE DESTINATION ${CMAKE_INSTALL_PREFIX})
+install(FILES xml/cluster.xml DESTINATION ${QPID_INSTALL_DATADIR})
if (WIN32)
set (CMAKE_DEBUG_POSTFIX "d")
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index ed3dd93cb0..8e0988c5c1 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -735,6 +735,9 @@ if (WIN32)
if (EXISTS ${DTC_PLUGIN_SOURCE})
add_library (qpidxarm SHARED ${DTC_PLUGIN_SOURCE})
target_link_libraries (qpidxarm qpidclient qpidcommon)
+ install (TARGETS qpidxarm
+ DESTINATION ${QPID_INSTALL_LIBDIR}
+ COMPONENT ${QPID_COMPONENT_CLIENT})
endif (EXISTS ${DTC_PLUGIN_SOURCE})
endif (WIN32)
diff --git a/qpid/packaging/windows/INSTALL_NOTES.html b/qpid/packaging/windows/INSTALL_NOTES.html
index 71eaf542b1..f875844425 100644
--- a/qpid/packaging/windows/INSTALL_NOTES.html
+++ b/qpid/packaging/windows/INSTALL_NOTES.html
@@ -1,11 +1,11 @@
<html>
<head>
-<title>Apache Qpid C++ 0.5 Release Notes</title>
+<title>Apache Qpid C++ 0.6 Installation Notes</title>
</head>
<body>
-<H1>Apache Qpid C++ 0.5 Installation Notes</H1>
+<H1>Apache Qpid C++ 0.6 Installation Notes</H1>
-<p>Thank you for installing the Apache Qpid version 0.5 C++ kit.
+<p>Thank you for installing the Apache Qpid version 0.6 for Windows kit.
If the requisite features were installed, you can now run a broker,
use the example programs, and design your own messaging programs while
reading the Qpid C++ API reference documentation.</p>
@@ -20,12 +20,12 @@ on the same system as the client, but it must be reachable using TCP/IP.</p>
<p>The broker executable is installed in the <code>bin</code> subdirectory
of your Qpid installation directory. The broker program is
-<code>qpidbroker.exe</code>. The simplest way to experiment with the
+<code>qpidd.exe</code>. The simplest way to experiment with the
broker is to open a command prompt window, cd to the installation
directory, and execute the broker:
<pre>
-cd "C:\Program Files\Apache\qpidc-0.5\bin"
-qpidbroker
+cd "C:\Program Files\Apache\qpidc-0.6\bin"
+qpidd
</pre>
A small amount of information will be displayed to let you know the broker
is running and listening for client connections.</p>
@@ -56,10 +56,52 @@ Documentation</i>. Selecting that menu item will launch the documentation's
main page in your default web browser.</p>
<H2>Complete Source Code is Available</H2>
-<p>If you installed the complete source code feature (which is disabled by
-default) you can explore all the source code for all of Apache Qpid. This
-includes the Visual Studio 2008 project files necessary for rebuilding Qpid
-should you wish to do so.</p>
+<p>If you wish to view Qpid's source code, please visit
+<a href="http://qpid.apache.org/download.html">
+http://qpid.apache.org/download.html</a>. The source components used to build
+this installed kit are "C++ broker &amp; client" and "C# (.NET, WCF) WCF
+channel (C++ Broker Compatible)."</p>
+
+<H1>Notes</H1>
+<p>Please read the following sections for important notes regarding this
+release.</p>
+<H2>WCF Channel</H2>
+<p>This release includes a new .NET WCF Channel implementation. The WCF DLL
+is named <code>Apache.Qpid.Channel.dll</code> located in the <code>bin</code>
+directory under the Qpid installation location.</p>
+<p>WCF Channel programming examples are located in the
+<code>examples\Channel</code> under the installation directory.</p>
+<p>The WCF Channel DLLs are not loaded into the Global Assembly Cache (GAC)
+at install time; therefore, they must be referenced explicitly from the install
+location.</p>
+<p>If you wish to install the WCF Channel DLLs into the GAC, you can use the
+following commands (assuming the Qpid install location is
+<code>C:\Program Files\Apache\qpidc-0.6</code>):</p>
+<pre>
+gacutil -I "C:\Program Files\Apache\qpidc-0.6\bin\Apache.Qpid.Channel.dll"
+gacutil -I "C:\Program Files\Apache\qpidc-0.6\bin\Apache.Qpid.Interop.dll"
+</pre>
+<p>To remove the DLLs from the GAC:</p>
+<pre>
+gacutil /u "Apache.Qpid.Channel"
+gacutil /u "Apache.Qpid.Interop"
+</pre>
+
+<H2>Broker Persistence Module</H2>
+<p>This release includes a new persistence module. The broker can use this
+module to facilitate durable queues, exchanges, bindings, configuration, and
+messages. The persistence module uses SQL Server Express (or SQL Server) 2005
+or newer. The persistence module is a Qpid broker plugin. It is not loaded by
+default; therefore, to gain support for durable items the persistence plugin
+must be loaded into the broker. This can be done using the
+<code>--module-dir</code> option to load all available plugins. For example:
+<pre>
+cd "C:\Program Files\Apache\qpidc-0.6"
+bin\qpidd.exe --module-dir plugins\broker
+</pre>
+The <code>--module-dir</code> option can also take a full path. The option
+can also be included in the broker configuration file. A sample is located
+in the <code>conf\qpidd.conf</code> file under the installation directory.</p>
<H1>For More Information</H1>
<p>For more information on Apache Qpid, please visit the web site
diff --git a/qpid/packaging/windows/build_installer.bat b/qpid/packaging/windows/build_installer.bat
index 705a4dd21e..addc33f32b 100644
--- a/qpid/packaging/windows/build_installer.bat
+++ b/qpid/packaging/windows/build_installer.bat
@@ -41,6 +41,13 @@ goto run
@set bits=64
:run
+rem Two environment variables need to be set:
+rem QPID_BUILD_ROOT: root of the build directory; $cwd\build unless the
+rem build_dir property is set in msbuild properties below.
+rem BOOST_ROOT: root of the Boost installation
+
+set QPID_BUILD_ROOT=%CD%\build
+
rem If the local cmake needs help, add options to the cmake_options property.
rem For example: cmake_options="-DBOOST_INCLUDE_DIR=C:/Boost/boost-1_40
rem -DBOOST_LIBRARYDIR=C:/Boost/boost-1_40/lib64"
diff --git a/qpid/packaging/windows/installer.proj b/qpid/packaging/windows/installer.proj
index 78679588bc..de68b05626 100644
--- a/qpid/packaging/windows/installer.proj
+++ b/qpid/packaging/windows/installer.proj
@@ -44,6 +44,7 @@
<ProgramFiles>ProgramFiles64Folder</ProgramFiles>
<CmakeGenerator>%22Visual Studio 9 2008 Win64%22</CmakeGenerator>
<Architecture>x64</Architecture>
+ <CSProjArchitecture>x64</CSProjArchitecture>
</PropertyGroup>
</When>
<Otherwise>
@@ -51,6 +52,7 @@
<ProgramFiles>ProgramFilesFolder</ProgramFiles>
<CmakeGenerator>%22Visual Studio 9 2008%22</CmakeGenerator>
<Architecture>x86</Architecture>
+ <CSProjArchitecture>Win32</CSProjArchitecture>
</PropertyGroup>
</Otherwise>
</Choose>
@@ -77,7 +79,7 @@
<WcfProjects Include="$(source_root)\wcf\src\Apache\Qpid\**\*.csproj"/>
<WcfArtifacts Include="$(source_root)\wcf\src\Apache\Qpid\Channel\bin\Release\*.dll"/>
<WcfExamples Include="$(source_root)\wcf\samples\**\*"
- Exclude="$(source_root)\wcf\samples\**\.svn\*"/>
+ Exclude="$(source_root)\wcf\samples\**\.svn\**"/>
</ItemGroup>
<ItemGroup>
@@ -134,7 +136,7 @@
<Target Name="BuildWcf" DependsOnTargets="BuildCpp">
<MSBuild
Projects="$(source_root)\wcf\QpidWcf.sln"
- Properties="Configuration=Release;Platform=$(Architecture)"
+ Properties="Configuration=Release;Platform=$(CSProjArchitecture)"
StopOnFirstFailure="false" />
</Target>
@@ -192,7 +194,7 @@
<Exec
Command="heat dir $(staging_dir)\docs\api -var var.api_docs_dir -dr QpidDoc -gg -cg group_APIDocs -out api_docs.wxs" />
<Exec
- Command="candle -dqpidc_version=0.6 -dstaging_dir=$(staging_dir) -dqpid_headers_dir=$(staging_dir)\include\qpid -dboost_headers_dir=$(staging_dir)\include\boost -dboost_dll_dir=$(staging_dir)\bin\boost -dexamples_dir=$(staging_dir)\examples -dapi_docs_dir=$(staging_dir)\docs\api qpidc.wxs qpid_headers.wxs boost_headers.wxs boost_dlls.wxs examples.wxs api_docs.wxs -arch $(Architecture)" />
+ Command="candle -dqpidc_version=0.6 -dProgramFiles=$(ProgramFiles) -dstaging_dir=$(staging_dir) -dqpid_headers_dir=$(staging_dir)\include\qpid -dboost_headers_dir=$(staging_dir)\include\boost -dboost_dll_dir=$(staging_dir)\bin\boost -dexamples_dir=$(staging_dir)\examples -dapi_docs_dir=$(staging_dir)\docs\api qpidc.wxs qpid_headers.wxs boost_headers.wxs boost_dlls.wxs examples.wxs api_docs.wxs -arch $(Architecture)" />
<Exec
Command="light -ext WixUtilExtension -ext WixUIExtension -cultures:en-us -out qpidc-0.6-$(Architecture).msi qpidc.wixobj qpid_headers.wixobj boost_headers.wixobj boost_dlls.wixobj examples.wixobj api_docs.wixobj" />
</Target>
diff --git a/qpid/packaging/windows/qpidc.wxs b/qpid/packaging/windows/qpidc.wxs
index c4a3bf9169..258beaaf3a 100644
--- a/qpid/packaging/windows/qpidc.wxs
+++ b/qpid/packaging/windows/qpidc.wxs
@@ -37,20 +37,22 @@
<Media Id="1" Cabinet="qpidc.cab" EmbedCab="yes" />
<!-- Allow 64-bit builds to pick ProgramFiles64Folder instead -->
- <? Define ProgramFiles = "ProgramFilesFolder"?>
+ <?Define ProgramFiles = "ProgramFilesFolder"?>
<Directory Id="TARGETDIR" Name="SourceDir">
<Directory Id="$(var.ProgramFiles)">
<Directory Id="ApacheTop" Name="Apache">
<Directory Id="INSTALLLOCATION" Name="qpidc-$(var.qpidc_version)">
<Directory Id="QpidBin" Name="bin"/>
- <Directory Id="QpidInclude" Name="include"/>
- <Directory Id="QpidExamples" Name="examples"/>
+ <Directory Id="QpidConf" Name="conf"/>
<Directory Id="QpidDoc" Name="docs">
- <Directory Id="QpidDocAPI" Name="api"/>
+ <Directory Id="QpidDocAPI" Name="api"/>
+ </Directory>
+ <Directory Id="QpidExamples" Name="examples"/>
+ <Directory Id="QpidInclude" Name="include"/>
+ <Directory Id="QpidPlugins" Name="plugins">
+ <Directory Id="QpidBrPlugin" Name="broker"/>
</Directory>
-<!-- Make this a link to the apache web site with the tarball -->
- <!-- Directory Id="QpidSrcDist" Name="srcdist"/ -->
</Directory>
</Directory>
</Directory>
@@ -64,6 +66,10 @@
<Component Id="InstallNotes" Guid="{10A64ABE-B3F7-40c0-88F1-E0AD71467A3E}">
<File Id="InstallNotesHTML" Source="INSTALL_NOTES.html"/>
</Component>
+ <Component Id="Legal" Guid="{D98B2A06-4A7E-488a-A7A9-BFB1B9D594A0}">
+ <File Id="LICENSE" Source="$(var.staging_dir)\LICENSE"/>
+ <File Id="NOTICE" Source="$(var.staging_dir)\NOTICE"/>
+ </Component>
</DirectoryRef>
<DirectoryRef Id="QpidBin">
@@ -113,11 +119,21 @@
</DirectoryRef>
- <!-- DirectoryRef Id="QpidSrcDist">
- <Component Id="DistroSrc" Guid="{0D2C11F3-B3B6-4d4b-9569-08097A4D0D1A}">
- <File Id="DistroTAR" Source="..\qpid-cpp-0.5.tar.gz"/>
+ <DirectoryRef Id="QpidConf">
+ <Component Id="BrokerConf" Guid="{8893D4B8-F87B-4da7-914A-87ED61E46577}">
+ <File Id="BrokerConfFile" Source="$(var.staging_dir)\conf\qpidd.conf"/>
+ </Component>
+ <Component Id="ClientConf" Guid="{2ED5B20C-9D57-4961-B928-6FC1436309F7}">
+ <File Id="ClientConfFile" Source="$(var.staging_dir)\conf\qpidc.conf"/>
</Component>
- </DirectoryRef -->
+ </DirectoryRef>
+
+ <DirectoryRef Id="QpidBrPlugin">
+ <Component Id="SQLPersistence" Guid="{DDF3AF70-C4E4-4745-BB7E-0E195FAF116B}">
+ <File Id="StorePlugin" Source="$(var.staging_dir)\plugins\broker\store.dll"/>
+ <File Id="SQLPlugin" Source="$(var.staging_dir)\plugins\broker\mssql_store.dll"/>
+ </Component>
+ </DirectoryRef>
<DirectoryRef Id="ApplicationProgramsFolder">
<Component Id="APIDocShortcut" Guid="{B95A28E2-E2B5-4f31-93C3-24B010701F30}">
@@ -134,14 +150,18 @@
Display="expand" ConfigurableDirectory="INSTALLLOCATION"
TypicalDefault="install">
<ComponentRef Id="InstallNotes"/>
+ <ComponentRef Id="Legal"/>
<Feature Id="Broker" Title="Broker: Routes and queues messages" Level="1">
+ <ComponentRef Id="BrokerConf"/>
<ComponentRef Id="Broker_Release"/>
<ComponentRef Id="CommonLib_Release"/>
+ <ComponentRef Id="SQLPersistence"/>
<ComponentGroupRef Id="group_BoostDlls"/>
</Feature>
<Feature Id="ClientLib" Title="Client Libraries and Headers to develop and run programs" Level="1">
+ <ComponentRef Id="ClientConf"/>
<ComponentRef Id="CommonLib_Debug"/>
<ComponentRef Id="CommonLib_Release"/>
<ComponentRef Id="ClientLib_Debug"/>