summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2010-11-12 18:04:19 +0000
committerAlan Conway <aconway@apache.org>2010-11-12 18:04:19 +0000
commit10a0a7c30343c15e51128bc3a11890298608ddbf (patch)
tree7873da8a8761076eb18e3b67fd3b6f5a6586df41
parent57dc1169da60ce91838151d8f45dd25b946f6db5 (diff)
downloadqpid-python-10a0a7c30343c15e51128bc3a11890298608ddbf.tar.gz
Include cluster scripts unconditionally in distribution.
Merged to 0.8 release branch from r1034008. git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/0.8-release-candidates@1034496 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/tests/cluster.mk59
1 files changed, 32 insertions, 27 deletions
diff --git a/qpid/cpp/src/tests/cluster.mk b/qpid/cpp/src/tests/cluster.mk
index da191e8682..51bd5930c9 100644
--- a/qpid/cpp/src/tests/cluster.mk
+++ b/qpid/cpp/src/tests/cluster.mk
@@ -17,6 +17,38 @@
# under the License.
#
+
+# Include cluster scripts and extra files in distribution even if
+# we're not configured for cluster.
+
+# Useful scripts for doing cluster testing.
+CLUSTER_TEST_SCRIPTS_LIST= \
+ allhosts rsynchosts \
+ qpid-build-rinstall qpid-src-rinstall \
+ qpid-test-cluster \
+ qpid-cluster-benchmark
+
+EXTRA_DIST += \
+ $(CLUSTER_TEST_SCRIPTS_LIST) \
+ ais_check \
+ run_cluster_test \
+ cluster_read_credit \
+ test_watchdog \
+ start_cluster \
+ stop_cluster \
+ restart_cluster \
+ cluster_python_tests \
+ cluster_python_tests_failing.txt \
+ federated_cluster_test \
+ clustered_replication_test \
+ run_cluster_tests \
+ run_long_cluster_tests \
+ testlib.py \
+ cluster_tests.py \
+ long_cluster_tests.py \
+ cluster_tests.fail
+
+
if HAVE_LIBCPG
#
@@ -40,25 +72,6 @@ TESTS += \
# Clean up after cluster_test and start_cluster
CLEANFILES += cluster_test.acl cluster.ports
-EXTRA_DIST += \
- ais_check \
- run_cluster_test \
- cluster_read_credit \
- test_watchdog \
- start_cluster \
- stop_cluster \
- restart_cluster \
- cluster_python_tests \
- cluster_python_tests_failing.txt \
- federated_cluster_test \
- clustered_replication_test \
- run_cluster_tests \
- run_long_cluster_tests \
- testlib.py \
- cluster_tests.py \
- long_cluster_tests.py \
- cluster_tests.fail
-
LONG_TESTS += \
run_long_cluster_tests \
start_cluster \
@@ -80,14 +93,6 @@ cluster_test_SOURCES = \
cluster_test_LDADD=$(lib_client) $(lib_broker) ../cluster.la -lboost_unit_test_framework
qpidtest_SCRIPTS += run_cluster_tests cluster_tests.py run_long_cluster_tests long_cluster_tests.py testlib.py cluster_tests.fail
-
-# Useful scripts for doing cluster testing.
-CLUSTER_TEST_SCRIPTS_LIST= \
- allhosts rsynchosts \
- qpid-build-rinstall qpid-src-rinstall \
- qpid-test-cluster \
- qpid-cluster-benchmark
qpidtest_SCRIPTS += $(CLUSTER_TEST_SCRIPTS_LIST)
-EXTRA_DIST += $(CLUSTER_TEST_SCRIPTS_LIST)
endif