summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenneth Anthony Giusti <kgiusti@apache.org>2010-11-18 14:11:07 +0000
committerKenneth Anthony Giusti <kgiusti@apache.org>2010-11-18 14:11:07 +0000
commit1adec0d44b39a8779fbd804232ff3631b84b0945 (patch)
tree1b6bc4a2cb171cbd195b015d849ef9c351dc48ad
parentb16eccb78151fad691c8f8d17ed88f9ea6ea6b65 (diff)
downloadqpid-python-1adec0d44b39a8779fbd804232ff3631b84b0945.tar.gz
merge from trunk
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/0.8-release-candidates@1036461 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/examples/qmf-console/Makefile.am1
-rw-r--r--qpid/cpp/examples/qmf-console/README.txt39
2 files changed, 40 insertions, 0 deletions
diff --git a/qpid/cpp/examples/qmf-console/Makefile.am b/qpid/cpp/examples/qmf-console/Makefile.am
index dd75df94f7..f4cbb7633c 100644
--- a/qpid/cpp/examples/qmf-console/Makefile.am
+++ b/qpid/cpp/examples/qmf-console/Makefile.am
@@ -48,6 +48,7 @@ examples_DATA= \
$(MAKEDIST)
EXTRA_DIST= \
+ README.txt \
CMakeLists.txt \
qmf-console_console.vcproj \
qmf-console_ping.vcproj \
diff --git a/qpid/cpp/examples/qmf-console/README.txt b/qpid/cpp/examples/qmf-console/README.txt
new file mode 100644
index 0000000000..2ee784cbc2
--- /dev/null
+++ b/qpid/cpp/examples/qmf-console/README.txt
@@ -0,0 +1,39 @@
+The QMF console library provides an interface infrastructure for
+broker management. This directory contains example applications that
+use the QMF console library to interact with the broker.
+
+cluster-qmon.cpp:
+This example maintains connections to a number of brokers (assumed to
+be running on localhost and at ports listed in the command line
+arguments). The program then periodically polls queue information
+from a single operational broker. This is a useful illustration of
+how one might monitor statistics on a cluster of brokers.
+
+console.cpp:
+A simple application that attaches to a broker (assumed to be
+available as "localhost:5672"), and extracts:
+ * Management Schema (packages and classes)
+ * Management state for all active Exchanges
+ * Management state for all active Queues
+It then invokes the broker's "echo" test method before detaching from
+the broker.
+
+ping.cpp:
+Connects to a broker (assumed to be available as "localhost:5672"),
+and invokes the "echo" test method five times.
+
+printevents.cpp:
+An example of a passive broker monitor. This application connects to
+a broker (assumed to be available as "localhost:5672"), and registers
+a callback listener. The listener's callbacks are invoked when
+various management events are signalled by the broker.
+
+queuestats.cpp:
+An example of a passive broker monitor. This application connects to
+a broker (assumed to be available as "localhost:5672"), and registers
+a callback listener for status updates only for Queue objects. The
+listener's callback is invoked whenever the status of a Queue
+changes.
+
+
+