summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2010-10-29 14:03:08 +0000
committerStephen D. Huston <shuston@apache.org>2010-10-29 14:03:08 +0000
commita2006968333a76594951f7356e83ba27a9e5a118 (patch)
tree3dbec1b90fc7c813b7ad160e07ed2648bdc971ca
parent7da23f2ec7b60e6a68e0a735b7aa3e1910605ffd (diff)
downloadqpid-python-a2006968333a76594951f7356e83ba27a9e5a118.tar.gz
Add missing hello_world and hello_xml examples. Resolves QPID-2919.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1028752 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/examples/messaging/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/qpid/cpp/examples/messaging/CMakeLists.txt b/qpid/cpp/examples/messaging/CMakeLists.txt
index 31195f0cf0..03ed2daaad 100644
--- a/qpid/cpp/examples/messaging/CMakeLists.txt
+++ b/qpid/cpp/examples/messaging/CMakeLists.txt
@@ -45,3 +45,19 @@ add_messaging_example(map_sender)
add_messaging_example(client)
add_messaging_example(server)
+
+# These don't need Boost or OptionParser
+add_executable(hello_world hello_world.cpp)
+set_target_properties(hello_world PROPERTIES OUTPUT_NAME hello_world)
+target_link_libraries(hello_world qpidmessaging)
+install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/hello_world.cpp
+ DESTINATION ${QPID_INSTALL_EXAMPLESDIR}/messaging
+ COMPONENT ${QPID_COMPONENT_EXAMPLES})
+
+add_executable(hello_xml hello_xml.cpp)
+set_target_properties(hello_xml PROPERTIES OUTPUT_NAME hello_xml)
+target_link_libraries(hello_xml qpidmessaging)
+install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/hello_xml.cpp
+ DESTINATION ${QPID_INSTALL_EXAMPLESDIR}/messaging
+ COMPONENT ${QPID_COMPONENT_EXAMPLES})
+