summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles E. Rolke <chug@apache.org>2010-11-05 18:51:00 +0000
committerCharles E. Rolke <chug@apache.org>2010-11-05 18:51:00 +0000
commita4e15268a8ddc544b7773e46847a466a799382a6 (patch)
tree41fe6546f9b2bc3f7aca291ab8b2abc742672f75
parenta80e01056292af33ccbe11a6937c49c01cbbaad6 (diff)
downloadqpid-python-a4e15268a8ddc544b7773e46847a466a799382a6.tar.gz
QPID-2926 Simple example code does not link under Windows
This commit provides a windows-only Handle instantiator for the currently known Handle consumers. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1031711 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt8
-rw-r--r--qpid/cpp/src/qpid/messaging/HandleInstantiator.cpp64
2 files changed, 72 insertions, 0 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index a1560cce2f..0df4fd0496 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -652,6 +652,10 @@ if (CMAKE_SYSTEM_NAME STREQUAL Windows)
set (qpidd_platform_SOURCES
windows/QpiddBroker.cpp
)
+
+ set (qpidmessaging_platform_SOURCES
+ qpid/messaging/HandleInstantiator.cpp
+ )
else (CMAKE_SYSTEM_NAME STREQUAL Windows)
@@ -718,6 +722,9 @@ else (CMAKE_SYSTEM_NAME STREQUAL Windows)
set (qpidd_platform_SOURCES
posix/QpiddBroker.cpp
)
+
+ set (qpidmessaging_platform_SOURCES
+ )
endif (CMAKE_SYSTEM_NAME STREQUAL Windows)
set (qpidcommon_SOURCES
@@ -866,6 +873,7 @@ install_pdb (qpidclient ${QPID_COMPONENT_CLIENT})
set (qpidmessaging_SOURCES
+ ${qpidmessaging_platform_SOURCES}
qpid/messaging/Address.cpp
qpid/messaging/AddressParser.h
qpid/messaging/AddressParser.cpp
diff --git a/qpid/cpp/src/qpid/messaging/HandleInstantiator.cpp b/qpid/cpp/src/qpid/messaging/HandleInstantiator.cpp
new file mode 100644
index 0000000000..c9a7680bb4
--- /dev/null
+++ b/qpid/cpp/src/qpid/messaging/HandleInstantiator.cpp
@@ -0,0 +1,64 @@
+/*
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements. See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership. The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License. You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied. See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ *
+ */
+#include "qpid/messaging/Connection.h"
+#include "qpid/messaging/Receiver.h"
+#include "qpid/messaging/Sender.h"
+#include "qpid/messaging/Session.h"
+
+namespace qpid {
+namespace messaging {
+
+using namespace qpid::types;
+
+void HandleInstantiatorDoNotCall(void)
+{
+ // This function exists to instantiate various template Handle
+ // bool functions. The instances are then available to
+ // the qpidmessaging DLL and subsequently exported.
+ // This function must not be exported nor called called.
+ // For further information refer to
+ // https://issues.apache.org/jira/browse/QPID-2926
+
+ Connection connection;
+ if (connection.isValid()) connection.close();
+ if (connection.isNull() ) connection.close();
+ if (connection ) connection.close();
+ if (!connection ) connection.close();
+
+ Receiver receiver;
+ if (receiver.isValid()) receiver.close();
+ if (receiver.isNull() ) receiver.close();
+ if (receiver ) receiver.close();
+ if (!receiver ) receiver.close();
+
+ Sender sender;
+ if (sender.isValid()) sender.close();
+ if (sender.isNull() ) sender.close();
+ if (sender ) sender.close();
+ if (!sender ) sender.close();
+
+ Session session;
+ if (session.isValid()) session.close();
+ if (session.isNull() ) session.close();
+ if (session ) session.close();
+ if (!session ) session.close();
+}
+}} // namespace qpid::messaging