summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2010-11-04 22:50:43 +0000
committerStephen D. Huston <shuston@apache.org>2010-11-04 22:50:43 +0000
commitc312421cb14c164c13be6dd23d5f7f9b9a37157a (patch)
tree91f39291f3d3979fa024188fccc7c98e0e229055
parent3a4ab013713b748c619112ea067fb9ff2a835c63 (diff)
downloadqpid-python-c312421cb14c164c13be6dd23d5f7f9b9a37157a.tar.gz
When running store tests, pass the store type to the script. Also added test runs for the CLFS store.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1031323 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/tests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/qpid/cpp/src/tests/CMakeLists.txt b/qpid/cpp/src/tests/CMakeLists.txt
index 4046481add..b9bfa35d94 100644
--- a/qpid/cpp/src/tests/CMakeLists.txt
+++ b/qpid/cpp/src/tests/CMakeLists.txt
@@ -293,8 +293,11 @@ if (BUILD_ACL)
add_test (acl_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_acl_tests${test_script_suffix})
endif (BUILD_ACL)
if (BUILD_MSSQL)
- add_test (store_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_store_tests${test_script_suffix})
+ add_test (store_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_store_tests${test_script_suffix} MSSQL)
endif (BUILD_MSSQL)
+if (BUILD_MSCLFS)
+ add_test (store_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_store_tests${test_script_suffix} MSSQL-CLFS)
+endif (BUILD_MSCLFS)
endif (PYTHON_EXECUTABLE)
add_library(test_store MODULE test_store.cpp)