summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Sim <gsim@apache.org>2010-10-27 09:44:57 +0000
committerGordon Sim <gsim@apache.org>2010-10-27 09:44:57 +0000
commitc4bafa4c2a626c0c7a952f6b19fc2a7f15c23793 (patch)
tree880ae425a34def7f1606e9b9de372ea1dce0a50f
parenta08fcd240574edf7e786fc84830aa6563965d33a (diff)
downloadqpid-python-c4bafa4c2a626c0c7a952f6b19fc2a7f15c23793.tar.gz
Added some missing licenses; added FedOps.h to distribution list
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1027879 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/etc/selinux/Makefile18
-rw-r--r--qpid/cpp/examples/makedist.mk18
-rw-r--r--qpid/cpp/examples/messaging/extra_dist/Makefile18
-rw-r--r--qpid/cpp/examples/messaging/hello_world.cpp21
-rw-r--r--qpid/cpp/examples/messaging/hello_xml.cpp21
-rwxr-xr-xqpid/cpp/rubygen/framing.0-10/MethodHolder.rb0
-rw-r--r--qpid/cpp/src/Makefile.am1
7 files changed, 97 insertions, 0 deletions
diff --git a/qpid/cpp/etc/selinux/Makefile b/qpid/cpp/etc/selinux/Makefile
index e44ec2224b..1ab6337114 100644
--- a/qpid/cpp/etc/selinux/Makefile
+++ b/qpid/cpp/etc/selinux/Makefile
@@ -1,3 +1,21 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
# Makefile to build and install the selinux policies in this directory.
# Needs to be run as root.
diff --git a/qpid/cpp/examples/makedist.mk b/qpid/cpp/examples/makedist.mk
index 0a7f18de76..c494af5e8f 100644
--- a/qpid/cpp/examples/makedist.mk
+++ b/qpid/cpp/examples/makedist.mk
@@ -1,3 +1,21 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
# Settings to build the examples in automake
AM_CXXFLAGS = $(WARNING_CFLAGS)
INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include
diff --git a/qpid/cpp/examples/messaging/extra_dist/Makefile b/qpid/cpp/examples/messaging/extra_dist/Makefile
index 9b8d07ec80..8dd7f658f7 100644
--- a/qpid/cpp/examples/messaging/extra_dist/Makefile
+++ b/qpid/cpp/examples/messaging/extra_dist/Makefile
@@ -1,3 +1,21 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
CXX=g++
CXXFLAGS=-g -O2
LDFLAGS=-lqpidmessaging
diff --git a/qpid/cpp/examples/messaging/hello_world.cpp b/qpid/cpp/examples/messaging/hello_world.cpp
index 8aef57d5d0..86342b3c47 100644
--- a/qpid/cpp/examples/messaging/hello_world.cpp
+++ b/qpid/cpp/examples/messaging/hello_world.cpp
@@ -1,3 +1,24 @@
+/*
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements. See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership. The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License. You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied. See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ *
+ */
+
#include <qpid/messaging/Connection.h>
#include <qpid/messaging/Message.h>
#include <qpid/messaging/Receiver.h>
diff --git a/qpid/cpp/examples/messaging/hello_xml.cpp b/qpid/cpp/examples/messaging/hello_xml.cpp
index ae72faaa47..6e9aa0ad6a 100644
--- a/qpid/cpp/examples/messaging/hello_xml.cpp
+++ b/qpid/cpp/examples/messaging/hello_xml.cpp
@@ -1,3 +1,24 @@
+/*
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements. See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership. The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License. You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied. See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ *
+ */
+
#include <qpid/messaging/Connection.h>
#include <qpid/messaging/Message.h>
#include <qpid/messaging/Receiver.h>
diff --git a/qpid/cpp/rubygen/framing.0-10/MethodHolder.rb b/qpid/cpp/rubygen/framing.0-10/MethodHolder.rb
deleted file mode 100755
index e69de29bb2..0000000000
--- a/qpid/cpp/rubygen/framing.0-10/MethodHolder.rb
+++ /dev/null
diff --git a/qpid/cpp/src/Makefile.am b/qpid/cpp/src/Makefile.am
index 9a6f7f3949..ea1672e1e1 100644
--- a/qpid/cpp/src/Makefile.am
+++ b/qpid/cpp/src/Makefile.am
@@ -543,6 +543,7 @@ libqpidbroker_la_SOURCES = \
qpid/broker/ExpiryPolicy.h \
qpid/broker/FanOutExchange.cpp \
qpid/broker/FanOutExchange.h \
+ qpid/broker/FedOps.h \
qpid/broker/HandlerImpl.h \
qpid/broker/HeadersExchange.cpp \
qpid/broker/HeadersExchange.h \