summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2009-01-08 20:57:19 +0000
committerTed Ross <tross@apache.org>2009-01-08 20:57:19 +0000
commitf0f86ca1080683bb26f1bf58042171784dc6716a (patch)
tree589262adabca9d13d6662c25918de3aabe7ab97a
parente030dc3157335a42db2740a826481982b151a7d5 (diff)
downloadqpid-python-f0f86ca1080683bb26f1bf58042171784dc6716a.tar.gz
Fixed automake files so c++ console headers are properly packaged.
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/M4-RCs@732824 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/Makefile.am4
-rw-r--r--qpid/cpp/src/qmf.mk4
-rw-r--r--qpid/cpp/src/qmfc.mk14
3 files changed, 20 insertions, 2 deletions
diff --git a/qpid/cpp/src/Makefile.am b/qpid/cpp/src/Makefile.am
index 114de01d44..422d456fa5 100644
--- a/qpid/cpp/src/Makefile.am
+++ b/qpid/cpp/src/Makefile.am
@@ -176,6 +176,7 @@ dmoduledir=$(libdir)/qpid/daemon
cmoduledir=$(libdir)/qpid/client
dmodule_LTLIBRARIES =
cmodule_LTLIBRARIES =
+module_hdr =
include cluster.mk
include acl.mk
@@ -464,6 +465,7 @@ libqpidclient_la_SOURCES = \
nobase_include_HEADERS = \
$(platform_hdr) \
+ $(module_hdr) \
qpid/amqp_0_10/apply.h \
qpid/assert.h \
qpid/Address.h \
@@ -488,8 +490,6 @@ nobase_include_HEADERS = \
qpid/memory.h \
qpid/shared_ptr.h \
qpid/Version.h \
- qpid/agent/ManagementAgent.h \
- qpid/agent/ManagementAgentImpl.h \
qpid/broker/Broker.h \
qpid/broker/AclModule.h \
qpid/broker/SessionAdapter.h \
diff --git a/qpid/cpp/src/qmf.mk b/qpid/cpp/src/qmf.mk
index a825971d51..f97d10e06f 100644
--- a/qpid/cpp/src/qmf.mk
+++ b/qpid/cpp/src/qmf.mk
@@ -22,6 +22,10 @@
#
lib_LTLIBRARIES += libqmfagent.la
+module_hdr += \
+ qpid/agent/ManagementAgent.h \
+ qpid/agent/ManagementAgentImpl.h
+
libqmfagent_la_SOURCES = \
qpid/agent/ManagementAgent.h \
qpid/agent/ManagementAgentImpl.cpp \
diff --git a/qpid/cpp/src/qmfc.mk b/qpid/cpp/src/qmfc.mk
index 089ac2dcd9..46e8d82f35 100644
--- a/qpid/cpp/src/qmfc.mk
+++ b/qpid/cpp/src/qmfc.mk
@@ -22,6 +22,20 @@
#
lib_LTLIBRARIES += libqmfconsole.la
+module_hdr += \
+ qpid/console/Agent.h \
+ qpid/console/Broker.h \
+ qpid/console/ClassKey.h \
+ qpid/console/ConsoleListener.h \
+ qpid/console/Event.h \
+ qpid/console/Object.h \
+ qpid/console/ObjectId.h \
+ qpid/console/Package.h \
+ qpid/console/Schema.h \
+ qpid/console/SequenceManager.h \
+ qpid/console/SessionManager.h \
+ qpid/console/Value.h
+
libqmfconsole_la_SOURCES = \
qpid/console/Agent.h \
qpid/console/Agent.cpp \