summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2012-02-17 19:04:32 +0000
committerAlan Conway <aconway@apache.org>2012-02-17 19:04:32 +0000
commit9cd34b79c2cba12e341e7e246cbe41841fb6e6a3 (patch)
tree1365377a0ae7ca83b70db6e31ad900ee5f60a194
parent1b56500400c5f846c8f828af3385b035b63f8f66 (diff)
downloadqpid-python-9cd34b79c2cba12e341e7e246cbe41841fb6e6a3.tar.gz
QPID-3603: Add HA tests to automake and cmake.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@1245706 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/src/tests/CMakeLists.txt1
-rw-r--r--cpp/src/tests/Makefile.am3
2 files changed, 3 insertions, 1 deletions
diff --git a/cpp/src/tests/CMakeLists.txt b/cpp/src/tests/CMakeLists.txt
index 16ae500140..75ecffe866 100644
--- a/cpp/src/tests/CMakeLists.txt
+++ b/cpp/src/tests/CMakeLists.txt
@@ -309,6 +309,7 @@ if (PYTHON_EXECUTABLE)
endif (PYTHON_EXECUTABLE)
add_test (stop_broker ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/stop_broker${test_script_suffix})
if (PYTHON_EXECUTABLE)
+ add_test (ha_tests ${test_wrap} ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/ha_tests.py)
add_test (ipv6_test ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/ipv6_test${test_script_suffix})
add_test (federation_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_federation_tests${test_script_suffix})
if (BUILD_ACL)
diff --git a/cpp/src/tests/Makefile.am b/cpp/src/tests/Makefile.am
index dcad71fee6..325019fb22 100644
--- a/cpp/src/tests/Makefile.am
+++ b/cpp/src/tests/Makefile.am
@@ -304,7 +304,8 @@ TESTS_ENVIRONMENT = \
system_tests = qpid-client-test quick_perftest quick_topictest run_header_test quick_txtest \
run_msg_group_tests
-TESTS += start_broker $(system_tests) python_tests stop_broker run_federation_tests run_federation_sys_tests \
+TESTS += start_broker $(system_tests) python_tests stop_broker \
+ ha_tests.py run_federation_tests run_federation_sys_tests \
run_acl_tests run_cli_tests replication_test dynamic_log_level_test \
run_queue_flow_limit_tests ipv6_test