summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2013-03-07 17:25:35 +0000
committerAlan Conway <aconway@apache.org>2013-03-07 17:25:35 +0000
commit74f4b51ba0cc95529b054e450cd6327f91520b6b (patch)
tree8c2b0923582ef384440460b358216138116319c6
parentcdc05fe8c2675454f86156501c610b6ddbcd7886 (diff)
downloadqpid-python-74f4b51ba0cc95529b054e450cd6327f91520b6b.tar.gz
QPID-4630: HA enable store tests if legacystore is built.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1453970 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/INSTALL3
-rw-r--r--qpid/cpp/src/tests/CMakeLists.txt3
-rwxr-xr-xqpid/cpp/src/tests/ha_store_tests.py4
-rw-r--r--qpid/cpp/src/tests/test_env.sh.in1
4 files changed, 8 insertions, 3 deletions
diff --git a/qpid/cpp/INSTALL b/qpid/cpp/INSTALL
index c503f8de19..770a16f72f 100644
--- a/qpid/cpp/INSTALL
+++ b/qpid/cpp/INSTALL
@@ -119,6 +119,9 @@ For the XML Exchange, include:
Optional ruby binding support include:
# yum install ruby ruby-devel swig
+Optional legacystore store module.
+# yum install libdb-cxx-devel libaio-devel
+
Follow the manual installation instruction below for any packages not
available through your distributions packaging tool.
diff --git a/qpid/cpp/src/tests/CMakeLists.txt b/qpid/cpp/src/tests/CMakeLists.txt
index 973421ed61..7a418993d5 100644
--- a/qpid/cpp/src/tests/CMakeLists.txt
+++ b/qpid/cpp/src/tests/CMakeLists.txt
@@ -324,6 +324,9 @@ endif (PYTHON_EXECUTABLE)
add_test (stop_broker ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/stop_broker${test_script_suffix})
if (PYTHON_EXECUTABLE)
add_test (ha_tests ${test_wrap} ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/ha_tests.py)
+ if (BUILD_LEGACYSTORE)
+ add_test (ha_store_tests ${test_wrap} ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/ha_store_tests.py)
+ endif (BUILD_LEGACYSTORE)
add_test (ipv6_test ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/ipv6_test${test_script_suffix})
add_test (federation_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_federation_tests${test_script_suffix})
add_test (federation_sys_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_federation_sys_tests${test_script_suffix})
diff --git a/qpid/cpp/src/tests/ha_store_tests.py b/qpid/cpp/src/tests/ha_store_tests.py
index d1eaca1b87..16bf6e2964 100755
--- a/qpid/cpp/src/tests/ha_store_tests.py
+++ b/qpid/cpp/src/tests/ha_store_tests.py
@@ -20,9 +20,7 @@
"""
This module contains tests for HA functionality that requires a store.
-It is not included as part of "make check" since it will not function
-without a store. Currently it can be run from a build of the message
-store.
+It will only be run if the STORE_LIB environment variable is defined.
"""
import os, signal, sys, time, imp, re, subprocess, glob, random, logging, shutil, math, unittest, random
diff --git a/qpid/cpp/src/tests/test_env.sh.in b/qpid/cpp/src/tests/test_env.sh.in
index 76e88283ed..0f8f834731 100644
--- a/qpid/cpp/src/tests/test_env.sh.in
+++ b/qpid/cpp/src/tests/test_env.sh.in
@@ -67,6 +67,7 @@ exportmodule SSLCONNECTOR_LIB sslconnector.so
exportmodule SSL_LIB ssl.so
exportmodule WATCHDOG_LIB watchdog.so
exportmodule XML_LIB xml.so
+exportmodule STORE_LIB legacystore.so
# Qpid options
export QPID_NO_MODULE_DIR=1 # Don't accidentally load installed modules