summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2014-01-17 17:28:14 +0000
committerAndrew Stitcher <astitcher@apache.org>2014-01-17 17:28:14 +0000
commit4cb13d096fd565ac8676b77570c2765601a93fbc (patch)
tree384996bd3e9f7007dd046872adfac9cd6db5eef2
parentee76ebefc53d00751fa0c2a404c083dc63f516db (diff)
downloadqpid-python-4cb13d096fd565ac8676b77570c2765601a93fbc.tar.gz
NO-JIRA: Really fix the test for the correct previous versions of cmake
(sorry, this is getting embarassing) git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1559198 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index 25726f9793..25f7e4a943 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -158,9 +158,9 @@ endif (VALGRIND_FOUND)
# TODO Need to rework CMake files to use INTERFACE_LINK_LIBRARIES target property
# When that is done we can remove the next 4 lines completely
set (CMAKE_LINK_INTERFACE_LIBRARIES "")
-if (DEFINED CMAKE_VERSION AND CMAKE_VERSION VERSION_GREATER "2.8.11")
+if (DEFINED CMAKE_VERSION AND NOT CMAKE_VERSION VERSION_LESS "2.8.12")
cmake_policy(SET CMP0022 OLD)
-endif (DEFINED CMAKE_VERSION AND CMAKE_VERSION VERSION_GREATER "2.8.11")
+endif (DEFINED CMAKE_VERSION AND NOT CMAKE_VERSION VERSION_LESS "2.8.12")
if (CMAKE_COMPILER_IS_GNUCXX)
# Warnings: Enable as many as possible, keep the code clean. Please