summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2014-01-16 23:03:24 +0000
committerAndrew Stitcher <astitcher@apache.org>2014-01-16 23:03:24 +0000
commit6c30c21e4b37837021164a2e0d538a45fe6c79df (patch)
tree4252239fa4ee84aeb92165e49ba62a76b71fd51d
parente074786f48659961a80f5c333578a7da5ec8629b (diff)
downloadqpid-python-6c30c21e4b37837021164a2e0d538a45fe6c79df.tar.gz
NO-JIRA: Turn off cmake warnings caused by change in recent cmake 2.8 versions
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1558954 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index c77b753727..c378c70fea 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -155,7 +155,10 @@ if (VALGRIND_FOUND)
endif (VALGRIND_FOUND)
# Do not keep on linking against transitive library dependencies
+# TODO Need to rework CMake files to use INTERFACE_LINK_LIBRARIES target property
+# When that is done we can remove the next 2 lines completely
set (CMAKE_LINK_INTERFACE_LIBRARIES "")
+cmake_policy(SET CMP0022 OLD)
if (CMAKE_COMPILER_IS_GNUCXX)
# Warnings: Enable as many as possible, keep the code clean. Please