summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2014-01-16 23:17:43 +0000
committerAndrew Stitcher <astitcher@apache.org>2014-01-16 23:17:43 +0000
commitb5a8f3813ed365e63b354581f9b4a624f0174a96 (patch)
treeb69017e2de5124dd70504168c0e02e63b47318d6
parent8a77ec82a1c3128a74e56c36e9a968604c9d2469 (diff)
downloadqpid-python-b5a8f3813ed365e63b354581f9b4a624f0174a96.tar.gz
NO-JIRA: fix to allow warning silencing to work on previous versions of cmake too
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1558960 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index c378c70fea..cace78902b 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -156,9 +156,11 @@ endif (VALGRIND_FOUND)
# Do not keep on linking against transitive library dependencies
# TODO Need to rework CMake files to use INTERFACE_LINK_LIBRARIES target property
-# When that is done we can remove the next 2 lines completely
+# When that is done we can remove the next 4 lines completely
set (CMAKE_LINK_INTERFACE_LIBRARIES "")
-cmake_policy(SET CMP0022 OLD)
+if (DEFINED CMAKE_VERSION AND CMAKE_VERSION VERSION_GREATER "2.8.11")
+ cmake_policy(SET CMP0022 OLD)
+endif (DEFINED CMAKE_VERSION AND CMAKE_VERSION VERSION_GREATER "2.8.11")
if (CMAKE_COMPILER_IS_GNUCXX)
# Warnings: Enable as many as possible, keep the code clean. Please