summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Ross <jross@apache.org>2016-04-21 18:08:03 +0000
committerJustin Ross <jross@apache.org>2016-04-21 18:08:03 +0000
commit12b8481e9a306b3adebc01abb0033913f07450c3 (patch)
treeda21db0134b50033c49e00129c44f9f7d93a8ae9
parent44ea83571de7df4fc0005b4c0555ca4da2a5af38 (diff)
downloadqpid-python-12b8481e9a306b3adebc01abb0033913f07450c3.tar.gz
QPID-7207: Improve the Qpid Python install and test instructions
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1740373 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/python/README.md18
1 files changed, 12 insertions, 6 deletions
diff --git a/qpid/python/README.md b/qpid/python/README.md
index bb1388ff17..25807a7990 100644
--- a/qpid/python/README.md
+++ b/qpid/python/README.md
@@ -19,16 +19,18 @@ Documentation can be found here:
## Getting started
-1. Make sure the Qpid Python client libraries are on your
- PYTHONPATH. If you have extracted the archive to the directory
- INSTALLPATH, the following export will work:
+1. Make sure the Qpid Python client libraries are on your PYTHONPATH.
+ Extract the archive and add the local directory to your PYTHONPATH:
- $ export PYTHONPATH=${PYTHONPATH}:${INSTALLPATH}/qpid-0.8/python
+ $ tar -xf qpid-python-VERSION.tar.gz
+ $ cd qpid-python-VERSION
+ $ export PYTHONPATH=$PWD:$PYTHONPATH
2. Make sure a broker is running.
3. Run the 'hello' example from qpid-0.8/python/examples/api:
+ $ cd examples/api
$ ./hello
Hello world!
@@ -69,17 +71,21 @@ selected as follows:
See the qpid-python-test usage for for additional options:
- ./qpid-python-test -h
+ $ ./qpid-python-test -h
## Installation
Other Qpid components depend on Qpid Python for testing. You can use
setup.py to install Qpid Python to a standard location:
+ # User-local install
+
$ python setup.py install --user
$ export PYTHONPATH=$HOME/.local/lib/python2.7/site-packages
$ export PATH=$HOME/.local/bin:$PATH
[or]
- $ python setup.py install # Uses established system paths
+ # System-wide install
+
+ $ sudo python setup.py install