summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2016-03-16 22:36:38 +0000
committerAndrew Stitcher <astitcher@apache.org>2016-03-16 22:36:38 +0000
commit3605c8d46ec051527255cb9dd20925ff6b73944a (patch)
tree4bab0f43499ae7aec786fba841b43ba6aa215eb7
parentacbd621de0e2de023c7aed041d58186bef808697 (diff)
downloadqpid-python-3605c8d46ec051527255cb9dd20925ff6b73944a.tar.gz
QPID-7145: Don't warn for using deprecated declarations (auto_ptr is now deprecated)
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1735328 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/qpid/cpp/CMakeLists.txt b/qpid/cpp/CMakeLists.txt
index 93ebd6ce05..8a6c541c22 100644
--- a/qpid/cpp/CMakeLists.txt
+++ b/qpid/cpp/CMakeLists.txt
@@ -139,7 +139,7 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
# -Wunreachable-code -Wpadded -Winline
# -Wshadow - warns about boost headers.
set (WARNING_FLAGS
- "-Werror -pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith -Wcast-qual -Wcast-align -Wno-long-long -Wvolatile-register-var -Winvalid-pch -Wno-system-headers -Woverloaded-virtual")
+ "-Werror -pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith -Wcast-qual -Wcast-align -Wno-long-long -Wvolatile-register-var -Winvalid-pch -Wno-system-headers -Woverloaded-virtual -Wno-error=deprecated-declarations")
set (CATCH_UNDEFINED "-Wl,--no-undefined")
# gcc on SunOS uses native linker whose "-z defs" is too fussy