summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles E. Rolke <chug@apache.org>2011-09-27 14:53:21 +0000
committerCharles E. Rolke <chug@apache.org>2011-09-27 14:53:21 +0000
commit60545fd0787cbba234d01606a195495a58222fef (patch)
treef086cd08389f857c175062be7a58b71383b1ba68
parent1373e098103ebb37a6a8749fdae915535248fe5b (diff)
downloadqpid-python-60545fd0787cbba234d01606a195495a58222fef.tar.gz
QPID-2574 Mismatch uint32_t / size_t
Suppress size mismatch warning in windows builds. The /wd4267 switch can be turned off when -Wconversion is turned on in gcc builds. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@1176412 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpp/src/CMakeLists.txt b/cpp/src/CMakeLists.txt
index d8496c5122..c8aedd4c60 100644
--- a/cpp/src/CMakeLists.txt
+++ b/cpp/src/CMakeLists.txt
@@ -598,6 +598,7 @@ if (CMAKE_SYSTEM_NAME STREQUAL Windows)
/wd4244
/wd4800
/wd4355
+ /wd4267
)
if (SET_WIN32_WINNT)
add_definitions(/D "_WIN32_WINNT=0x0502")