summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKim van der Riet <kpvdr@apache.org>2012-05-09 17:28:34 +0000
committerKim van der Riet <kpvdr@apache.org>2012-05-09 17:28:34 +0000
commit7ed6d96613a02d53a34a5c8e8d524a0b3c19d83d (patch)
tree08c811105b9bb57e1dc3eb95b0e9ca3bf4d8c442
parent2e3690efe94e6161d129ebce2f8c22cb25819ec1 (diff)
downloadqpid-python-7ed6d96613a02d53a34a5c8e8d524a0b3c19d83d.tar.gz
QPID-3858: Fixed condition variable wait loop, minor updates to cmake builds
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/asyncstore@1336306 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/src/CMakeLists.txt2
-rw-r--r--cpp/src/tests/CMakeLists.txt10
-rw-r--r--cpp/src/tests/storePerfTools/asyncPerf/MockPersistableQueue.cpp2
3 files changed, 6 insertions, 8 deletions
diff --git a/cpp/src/CMakeLists.txt b/cpp/src/CMakeLists.txt
index dd5b6b6341..36c0e0aa69 100644
--- a/cpp/src/CMakeLists.txt
+++ b/cpp/src/CMakeLists.txt
@@ -1515,7 +1515,7 @@ if (UNIX)
)
set_target_properties (asyncStore PROPERTIES
PREFIX ""
- OUTPUT_NAME qpidAsyncStore
+ OUTPUT_NAME asyncStore
SOVERSION ${asyncStore_version}
)
target_link_libraries (asyncStore
diff --git a/cpp/src/tests/CMakeLists.txt b/cpp/src/tests/CMakeLists.txt
index 965e4b2b38..54fc4fdf2d 100644
--- a/cpp/src/tests/CMakeLists.txt
+++ b/cpp/src/tests/CMakeLists.txt
@@ -369,7 +369,6 @@ if (UNIX)
add_executable (jrnl2Perf ${jrnl2Perf_SOURCES})
set_target_properties (jrnl2Perf PROPERTIES
COMPILE_FLAGS "-DJOURNAL2"
- LINK_FLAGS "-L${QPID_BUILD_DIR}/src"
)
target_link_libraries (jrnl2Perf
asyncStore
@@ -379,7 +378,7 @@ if (UNIX)
endif (UNIX)
# Async store perf test (asyncPerf)
-set (asyncPerf_SOURCES
+set (asyncStorePerf_SOURCES
storePerfTools/asyncPerf/MockPersistableMessage.cpp
storePerfTools/asyncPerf/MockPersistableQueue.cpp
storePerfTools/asyncPerf/MockTransactionContext.cpp
@@ -400,12 +399,11 @@ set (asyncPerf_SOURCES
)
if (UNIX)
- add_executable (asyncPerf ${asyncPerf_SOURCES})
- set_target_properties (asyncPerf PROPERTIES
+ add_executable (asyncStorePerf ${asyncStorePerf_SOURCES})
+ set_target_properties (asyncStorePerf PROPERTIES
COMPILE_FLAGS "-DJOURNAL2"
- LINK_FLAGS "-L${QPID_BUILD_DIR}/src"
)
- target_link_libraries (asyncPerf
+ target_link_libraries (asyncStorePerf
boost_program_options
asyncStore
qpidbroker
diff --git a/cpp/src/tests/storePerfTools/asyncPerf/MockPersistableQueue.cpp b/cpp/src/tests/storePerfTools/asyncPerf/MockPersistableQueue.cpp
index ff9b76c421..3b92af9803 100644
--- a/cpp/src/tests/storePerfTools/asyncPerf/MockPersistableQueue.cpp
+++ b/cpp/src/tests/storePerfTools/asyncPerf/MockPersistableQueue.cpp
@@ -323,7 +323,7 @@ void
MockPersistableQueue::pop(QueuedMessagePtr& qm)
{
qpid::sys::ScopedLock<qpid::sys::Mutex> l(m_enqueuedMsgsMutex);
- if (m_enqueuedMsgs.empty()) {
+ while (m_enqueuedMsgs.empty()) {
m_dequeueCondition.wait(m_enqueuedMsgsMutex);
}
qm = m_enqueuedMsgs.front();