summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-03-13 23:10:31 +0000
committerAlan Conway <aconway@apache.org>2007-03-13 23:10:31 +0000
commitf627ac7ef1c409275b73f5f330da260fe90ad64b (patch)
tree03025aa0039a71bbfa9444d61f1c981a9c2e0558
parent82cdcab7be84c8b17a01767785d424e356a25c32 (diff)
downloadqpid-python-f627ac7ef1c409275b73f5f330da260fe90ad64b.tar.gz
Merged revisions 499845 via svnmerge from
https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid ........ r499845 | aconway | 2007-01-25 11:45:48 -0500 (Thu, 25 Jan 2007) | 5 lines * qpidc.spec.in: updated to release 3 for RPM. * gen/make-gen-src-mk.sh: fixed problem with makefile generation in a new checkout. * Other Makefile.am: added missing files to maintainer-clean. * Added missing svn-ignores. ........ git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/branches/qpid.0-9@517931 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/qpidc.spec.in5
-rw-r--r--cpp/rpm/Makefile.am9
-rw-r--r--cpp/tests/Makefile.am3
3 files changed, 12 insertions, 5 deletions
diff --git a/cpp/qpidc.spec.in b/cpp/qpidc.spec.in
index fb1cd3cb22..d6d0288d63 100644
--- a/cpp/qpidc.spec.in
+++ b/cpp/qpidc.spec.in
@@ -5,7 +5,7 @@
Name: @PACKAGE@
Version: @VERSION@
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Libraries for Qpid C++ client applications
Group: System Environment/Libraries
License: Apache Software License
@@ -137,3 +137,6 @@ fi
* Fri Dec 8 2006 David Lutterkort <dlutter@redhat.com> - 0.1-1
- Initial version based on Jim Meyering's sketch and discussions with Alan
Conway
+
+* Thu Jan 25 Alan Conway <aconway@redhat.com> - 0.1-3
+- Applied Jim Meyereings fixes from http://mail-archives.apache.org/mod_mbox/incubator-qpid-dev/200701.mbox/%3c87hcugzmyp.fsf@rho.meyering.net%3e
diff --git a/cpp/rpm/Makefile.am b/cpp/rpm/Makefile.am
index 92a190aa0d..7f3a4b4b6b 100644
--- a/cpp/rpm/Makefile.am
+++ b/cpp/rpm/Makefile.am
@@ -13,11 +13,12 @@ clean-local:
.PHONY: rpm srpm dist
# Build source and binary RPMs.
-rpm: dist
- rpmbuild $(RPMOPTS) -ba $(SPEC)
+rpm: dist
+ rpmbuild $(RPMOPTS) $(RPMEXTRAOPTS) -ba $(SPEC)
+ rpmlint RPMS/*.rpm
-# Source RPM only.
-srpm: dist
+# Build source RPM only.
+srpm: dist
rpmbuild $(RPMOPTS) -bs $(SPEC)
# Build source distribution and create required subdirs.
diff --git a/cpp/tests/Makefile.am b/cpp/tests/Makefile.am
index 635e7b9371..59bb1b82e9 100644
--- a/cpp/tests/Makefile.am
+++ b/cpp/tests/Makefile.am
@@ -90,6 +90,9 @@ EXTRA_DIST = \
topictest \
APRBaseTest.cpp
+CLEANFILES=qpidd.log
+DISTCLEANFILES=gen.mk
+
include gen.mk
abs_builddir = @abs_builddir@