summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2009-04-21 20:32:17 +0000
committerStephen D. Huston <shuston@apache.org>2009-04-21 20:32:17 +0000
commitd9dc7bbf8ac82c1b6535d7a6b7e84b0725b4e105 (patch)
tree769da88a46c3f3c0a2948504347e026f3b7671a0
parent12ac7507a510e5bf12dcf93f0e0998795bb2f37e (diff)
downloadqpid-python-d9dc7bbf8ac82c1b6535d7a6b7e84b0725b4e105.tar.gz
Add the acl plugin
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/cmake@767286 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index 5b42e72a37..350d44d5f5 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -222,6 +222,22 @@ if (QPID_HAS_XML)
LINK_FLAGS -Wl,--no-undefined)
endif (QPID_HAS_XML)
+# Build the ACL plugin
+set (acl_SOURCES
+ qpid/acl/Acl.cpp
+ qpid/acl/Acl.h
+ qpid/acl/AclData.cpp
+ qpid/acl/AclData.h
+ qpid/acl/AclPlugin.cpp
+ qpid/acl/AclReader.cpp
+ qpid/acl/AclReader.h
+ )
+ add_library (acl SHARED ${acl_SOURCES})
+ target_link_libraries (acl qpidbroker)
+ set_target_properties (acl PROPERTIES
+ VERSION ${qpidc_version}
+ LINK_FLAGS -Wl,--no-undefined)
+
# Check for optional cluster support requirements
include (cluster.cmake)