summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDarryl L. Pierce <mcpierce@apache.org>2012-12-06 20:33:45 +0000
committerDarryl L. Pierce <mcpierce@apache.org>2012-12-06 20:33:45 +0000
commit6d565ecf62d258bd3a52d4d9bc89a9691003aeb6 (patch)
tree8840285def45b03f2d60055aace4e4cfde9aca37
parent8f0df4c367baa9df808e617e2fe23197f74173e2 (diff)
downloadqpid-python-6d565ecf62d258bd3a52d4d9bc89a9691003aeb6.tar.gz
QPID-4415: Fixes Perl bindings install location
Removed the DESTDIR option in the Makefile.am file for the Qpid language bindings for Perl. Also includes a fix from Jimmy Jones to remove the LIB argument to Makefile.PL to ensure the install location is correct. git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/0.20@1418058 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/bindings/qpid/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/qpid/cpp/bindings/qpid/Makefile.am b/qpid/cpp/bindings/qpid/Makefile.am
index 96e2a58414..b3849a6d28 100644
--- a/qpid/cpp/bindings/qpid/Makefile.am
+++ b/qpid/cpp/bindings/qpid/Makefile.am
@@ -44,7 +44,7 @@ perl/cqpid_perl.cpp: $(srcdir)/perl/perl.i $(srcdir)/qpid.i $(srcdir)/../swig_pe
perl/Makefile: perl/cqpid_perl.cpp
cd perl; \
- $(PERL) Makefile.PL PREFIX=$(prefix) LIB=$(PERL_ARCHLIB) ; \
+ $(PERL) Makefile.PL PREFIX=$(prefix) ; \
cd ..
all-local: perl/Makefile
@@ -54,7 +54,7 @@ all-local: perl/Makefile
install-exec-local:
cd perl ; \
- $(MAKE) pure_install DESTDIR=$(prefix) ; \
+ $(MAKE) pure_install ; \
cd ..
clean-local: