summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles E. Rolke <chug@apache.org>2011-02-23 02:31:34 +0000
committerCharles E. Rolke <chug@apache.org>2011-02-23 02:31:34 +0000
commit48591d6c55e4ffa9abde55312a5495d4b2b32349 (patch)
treefc12e013a3ebaa3c19275f2655e9028a4e58c2b6
parent5b1643601ca4ae55d62ac35c6328f935b1370425 (diff)
downloadqpid-python-48591d6c55e4ffa9abde55312a5495d4b2b32349.tar.gz
QPID-3061 Discrepancies between Cmake and Automake
Add four CMakeLists.txt files to automake so that the files are copied into the qpid-cpp source distribution kit. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1073580 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/bindings/qpid/Makefile.am2
-rw-r--r--qpid/cpp/bindings/qpid/perl/Makefile.am2
-rw-r--r--qpid/cpp/bindings/qpid/python/Makefile.am2
-rw-r--r--qpid/cpp/bindings/qpid/ruby/Makefile.am2
4 files changed, 4 insertions, 4 deletions
diff --git a/qpid/cpp/bindings/qpid/Makefile.am b/qpid/cpp/bindings/qpid/Makefile.am
index ca9eda0c73..31bce5d1d5 100644
--- a/qpid/cpp/bindings/qpid/Makefile.am
+++ b/qpid/cpp/bindings/qpid/Makefile.am
@@ -21,7 +21,7 @@ SUBDIRS = dotnet
if HAVE_SWIG
-EXTRA_DIST = qpid.i
+EXTRA_DIST = CMakeLists.txt qpid.i
if HAVE_RUBY_DEVEL
SUBDIRS += ruby
diff --git a/qpid/cpp/bindings/qpid/perl/Makefile.am b/qpid/cpp/bindings/qpid/perl/Makefile.am
index 13ab66f032..9e47786b8a 100644
--- a/qpid/cpp/bindings/qpid/perl/Makefile.am
+++ b/qpid/cpp/bindings/qpid/perl/Makefile.am
@@ -21,7 +21,7 @@ if HAVE_PERL_DEVEL
INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)/src -I$(top_builddir)/src -I$(PERL_INC)
-EXTRA_DIST = perl.i
+EXTRA_DIST = CMakeLists.txt perl.i
BUILT_SOURCES = cqpid_perl.cpp
SWIG_FLAGS = -w362,401
diff --git a/qpid/cpp/bindings/qpid/python/Makefile.am b/qpid/cpp/bindings/qpid/python/Makefile.am
index 7fa4106be0..9aef179db7 100644
--- a/qpid/cpp/bindings/qpid/python/Makefile.am
+++ b/qpid/cpp/bindings/qpid/python/Makefile.am
@@ -25,7 +25,7 @@ generated_file_list = \
cqpid.cpp \
cqpid.py
-EXTRA_DIST = python.i
+EXTRA_DIST = CMakeLists.txt python.i
BUILT_SOURCES = $(generated_file_list)
SWIG_FLAGS = -w362,401
diff --git a/qpid/cpp/bindings/qpid/ruby/Makefile.am b/qpid/cpp/bindings/qpid/ruby/Makefile.am
index 67a3615362..34f9990574 100644
--- a/qpid/cpp/bindings/qpid/ruby/Makefile.am
+++ b/qpid/cpp/bindings/qpid/ruby/Makefile.am
@@ -21,7 +21,7 @@ if HAVE_RUBY_DEVEL
INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)/src -I$(top_builddir)/src
-EXTRA_DIST = ruby.i
+EXTRA_DIST = CMakeLists.txt ruby.i
BUILT_SOURCES = cqpid.cpp
SWIG_FLAGS = -w362,401