summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2011-02-21 19:22:36 +0000
committerTed Ross <tross@apache.org>2011-02-21 19:22:36 +0000
commit85503e9d432236661b9deff68f319b6d7c89a9a3 (patch)
tree9b5f406cb8d59f12361d087c0a755516db8c5cb2
parentf96147fe36b4633e6f974a913e2a13b16ee5782a (diff)
downloadqpid-python-85503e9d432236661b9deff68f319b6d7c89a9a3.tar.gz
QPID-3061 - Consolidated the Swig warning-suppressions into one file.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1073121 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/bindings/qpid/CMakeLists.txt2
-rw-r--r--qpid/cpp/bindings/qpid/perl/CMakeLists.txt1
-rw-r--r--qpid/cpp/bindings/qpid/python/CMakeLists.txt1
-rw-r--r--qpid/cpp/bindings/qpid/ruby/CMakeLists.txt1
4 files changed, 2 insertions, 3 deletions
diff --git a/qpid/cpp/bindings/qpid/CMakeLists.txt b/qpid/cpp/bindings/qpid/CMakeLists.txt
index b44065d32f..7c9f76f991 100644
--- a/qpid/cpp/bindings/qpid/CMakeLists.txt
+++ b/qpid/cpp/bindings/qpid/CMakeLists.txt
@@ -25,6 +25,8 @@ include(FindPythonLibs)
include(FindPerlLibs)
if (SWIG_FOUND)
+ set(CMAKE_SWIG_FLAGS "-w361,362,401,467,503")
+
if (PYTHONLIBS_FOUND)
add_subdirectory(python)
endif (PYTHONLIBS_FOUND)
diff --git a/qpid/cpp/bindings/qpid/perl/CMakeLists.txt b/qpid/cpp/bindings/qpid/perl/CMakeLists.txt
index da3c0be41a..92ec5340e0 100644
--- a/qpid/cpp/bindings/qpid/perl/CMakeLists.txt
+++ b/qpid/cpp/bindings/qpid/perl/CMakeLists.txt
@@ -20,7 +20,6 @@
##------------------------------------------------------
## Use Swig to generate a literal binding to the C++ API
##------------------------------------------------------
-set(CMAKE_SWIG_FLAGS "-w361,362,401,467,503")
set_source_files_properties(${CMAKE_CURRENT_SOURCE_DIR}/perl.i PROPERTIES CPLUSPLUS ON)
set_source_files_properties(${CMAKE_CURRENT_SOURCE_DIR}/perl.i PROPERTIES SWIG_FLAGS "-I${qpid-cpp_SOURCE_DIR}/include")
diff --git a/qpid/cpp/bindings/qpid/python/CMakeLists.txt b/qpid/cpp/bindings/qpid/python/CMakeLists.txt
index 51c983f3cf..5e4649cd7c 100644
--- a/qpid/cpp/bindings/qpid/python/CMakeLists.txt
+++ b/qpid/cpp/bindings/qpid/python/CMakeLists.txt
@@ -20,7 +20,6 @@
##------------------------------------------------------
## Use Swig to generate a literal binding to the C++ API
##------------------------------------------------------
-set(CMAKE_SWIG_FLAGS "-w361,362,401,467")
set_source_files_properties(${CMAKE_CURRENT_SOURCE_DIR}/python.i PROPERTIES CPLUSPLUS ON)
set_source_files_properties(${CMAKE_CURRENT_SOURCE_DIR}/python.i PROPERTIES SWIG_FLAGS "-I${qpid-cpp_SOURCE_DIR}/include")
diff --git a/qpid/cpp/bindings/qpid/ruby/CMakeLists.txt b/qpid/cpp/bindings/qpid/ruby/CMakeLists.txt
index 7113d93b62..d403f3fdee 100644
--- a/qpid/cpp/bindings/qpid/ruby/CMakeLists.txt
+++ b/qpid/cpp/bindings/qpid/ruby/CMakeLists.txt
@@ -20,7 +20,6 @@
##------------------------------------------------------
## Use Swig to generate a literal binding to the C++ API
##------------------------------------------------------
-set(CMAKE_SWIG_FLAGS "-w361,362,401,467")
set_source_files_properties(${CMAKE_CURRENT_SOURCE_DIR}/ruby.i PROPERTIES CPLUSPLUS ON)
set_source_files_properties(${CMAKE_CURRENT_SOURCE_DIR}/ruby.i PROPERTIES SWIG_FLAGS "-I${qpid-cpp_SOURCE_DIR}/include")