summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Santos <nsantos@apache.org>2011-02-14 15:39:43 +0000
committerNuno Santos <nsantos@apache.org>2011-02-14 15:39:43 +0000
commitee017c5da0c9f17132132345c5b735d3421a07d8 (patch)
treef9907990a14bbf2741e03bf4482dabe3bf6ad1a0
parent87515049a36ba1cfc24378cb231188a83c9dd5e7 (diff)
downloadqpid-python-ee017c5da0c9f17132132345c5b735d3421a07d8.tar.gz
compatibility with newer (1.46) boost version by explicitly defining which version of boost_filesystem to use
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1070525 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/qpid/cpp/src/Makefile.am b/qpid/cpp/src/Makefile.am
index c50fa5a6da..fc93653017 100644
--- a/qpid/cpp/src/Makefile.am
+++ b/qpid/cpp/src/Makefile.am
@@ -127,6 +127,8 @@ qpidtest_SCRIPTS =
tmoduledir = $(libdir)/qpid/tests
tmodule_LTLIBRARIES=
+AM_CXXFLAGS += -DBOOST_FILESYSTEM_VERSION=2
+
## Automake macros to build libraries and executables.
qpidd_CXXFLAGS = $(AM_CXXFLAGS) -DQPIDD_MODULE_DIR=\"$(dmoduledir)\" -DQPIDD_CONF_FILE=\"$(sysconfdir)/qpidd.conf\"
libqpidclient_la_CXXFLAGS = $(AM_CXXFLAGS) -DQPIDC_MODULE_DIR=\"$(cmoduledir)\" -DQPIDC_CONF_FILE=\"$(confdir)/qpidc.conf\"