summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Goulish <mgoulish@apache.org>2011-03-08 20:59:26 +0000
committerMichael Goulish <mgoulish@apache.org>2011-03-08 20:59:26 +0000
commit6e790a04de3b94a702677e5c70ff39ab147e1050 (patch)
treefb944d089ac77d59679f0613e77dc6be2ae500c3
parent9a40feaeac53cfa754f15942144dc07108d7d076 (diff)
downloadqpid-python-6e790a04de3b94a702677e5c70ff39ab147e1050.tar.gz
QPID-1672
clustered versions of the 4 federated sasl external tests. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1079539 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/tests/sasl.mk2
-rwxr-xr-xqpid/cpp/src/tests/sasl_fed_ex14
-rwxr-xr-xqpid/cpp/src/tests/sasl_fed_ex_dynamic_cluster27
-rwxr-xr-xqpid/cpp/src/tests/sasl_fed_ex_link_cluster27
-rwxr-xr-xqpid/cpp/src/tests/sasl_fed_ex_queue_cluster27
-rwxr-xr-xqpid/cpp/src/tests/sasl_fed_ex_route_cluster27
6 files changed, 118 insertions, 6 deletions
diff --git a/qpid/cpp/src/tests/sasl.mk b/qpid/cpp/src/tests/sasl.mk
index c13ef95098..9947e8e27e 100644
--- a/qpid/cpp/src/tests/sasl.mk
+++ b/qpid/cpp/src/tests/sasl.mk
@@ -30,7 +30,7 @@ check_PROGRAMS+=sasl_version
sasl_version_SOURCES=sasl_version.cpp
sasl_version_LDADD=$(lib_client)
-TESTS += run_cluster_authentication_test sasl_fed sasl_fed_ex_dynamic sasl_fed_ex_link sasl_fed_ex_queue sasl_fed_ex_route
+TESTS += run_cluster_authentication_test sasl_fed sasl_fed_ex_dynamic sasl_fed_ex_link sasl_fed_ex_queue sasl_fed_ex_route sasl_fed_ex_route_cluster sasl_fed_ex_link_cluster sasl_fed_ex_queue_cluster sasl_fed_ex_dynamic_cluster
LONG_TESTS += run_cluster_authentication_soak
EXTRA_DIST += run_cluster_authentication_test sasl_fed sasl_fed_ex run_cluster_authentication_soak sasl_fed_ex_dynamic sasl_fed_ex_link sasl_fed_ex_queue sasl_fed_ex_route
diff --git a/qpid/cpp/src/tests/sasl_fed_ex b/qpid/cpp/src/tests/sasl_fed_ex
index f10f6e6446..71dece56a9 100755
--- a/qpid/cpp/src/tests/sasl_fed_ex
+++ b/qpid/cpp/src/tests/sasl_fed_ex
@@ -124,6 +124,10 @@ DST_TCP_PORT=5807
SRC_TCP_PORT_2=5802
DST_TCP_PORT_2=5803
+CLUSTER_1_NAME=sasl_fed_ex_cluster_1
+CLUSTER_2_NAME=sasl_fed_ex_cluster_2
+
+
SSL_LIB=${moduledir}/ssl.so
CLUSTER_LIB=${moduledir}/cluster.so
@@ -182,7 +186,7 @@ function start_brokers {
--port=${SRC_TCP_PORT} \
--ssl-port ${SRC_SSL_PORT} \
${COMMON_BROKER_OPTIONS} \
- --cluster-name sasl_fed_ex_cluster \
+ --cluster-name ${CLUSTER_1_NAME} \
--log-to-file $tmp_root/qpidd_src.log 2> /dev/null
broker_ports[0]=${SRC_TCP_PORT}
@@ -192,7 +196,7 @@ function start_brokers {
--port=${SRC_TCP_PORT_2} \
--ssl-port ${SRC_SSL_PORT_2} \
${COMMON_BROKER_OPTIONS} \
- --cluster-name sasl_fed_ex_cluster \
+ --cluster-name ${CLUSTER_1_NAME} \
--log-to-file $tmp_root/qpidd_src_2.log 2> /dev/null
broker_ports[1]=${SRC_TCP_PORT_2}
@@ -205,7 +209,7 @@ function start_brokers {
--port=${DST_TCP_PORT} \
--ssl-port ${DST_SSL_PORT} \
${COMMON_BROKER_OPTIONS} \
- --cluster-name sasl_fed_ex_cluster \
+ --cluster-name ${CLUSTER_2_NAME} \
--log-to-file $tmp_root/qpidd_dst.log 2> /dev/null
broker_ports[2]=${DST_TCP_PORT}
@@ -215,7 +219,7 @@ function start_brokers {
--port=${DST_TCP_PORT_2} \
--ssl-port ${DST_SSL_PORT_2} \
${COMMON_BROKER_OPTIONS} \
- --cluster-name sasl_fed_ex_cluster \
+ --cluster-name ${CLUSTER_2_NAME} \
--log-to-file $tmp_root/qpidd_dst_2.log 2> /dev/null
broker_ports[3]=${DST_TCP_PORT_2}
@@ -316,11 +320,11 @@ fi
# to avoid false negatives.
sleep 5
+# This should work the same whether or not we are running a clustered test.
print "check the link"
link_status=$($QPID_ROUTE_EXEC link list localhost:${DST_TCP_PORT} | tail -1 | awk '{print $5}')
print "link_status == ${link_status}"
-
halt_brokers
sleep 1
diff --git a/qpid/cpp/src/tests/sasl_fed_ex_dynamic_cluster b/qpid/cpp/src/tests/sasl_fed_ex_dynamic_cluster
new file mode 100755
index 0000000000..273a543ec5
--- /dev/null
+++ b/qpid/cpp/src/tests/sasl_fed_ex_dynamic_cluster
@@ -0,0 +1,27 @@
+#! /bin/bash
+
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+
+source ./test_env.sh
+
+${srcdir}/sasl_fed_ex dynamic cluster
+
+
diff --git a/qpid/cpp/src/tests/sasl_fed_ex_link_cluster b/qpid/cpp/src/tests/sasl_fed_ex_link_cluster
new file mode 100755
index 0000000000..0e037b1969
--- /dev/null
+++ b/qpid/cpp/src/tests/sasl_fed_ex_link_cluster
@@ -0,0 +1,27 @@
+#! /bin/bash
+
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+
+source ./test_env.sh
+
+${srcdir}/sasl_fed_ex link cluster
+
+
diff --git a/qpid/cpp/src/tests/sasl_fed_ex_queue_cluster b/qpid/cpp/src/tests/sasl_fed_ex_queue_cluster
new file mode 100755
index 0000000000..ec8750b861
--- /dev/null
+++ b/qpid/cpp/src/tests/sasl_fed_ex_queue_cluster
@@ -0,0 +1,27 @@
+#! /bin/bash
+
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+
+source ./test_env.sh
+
+${srcdir}/sasl_fed_ex queue cluster
+
+
diff --git a/qpid/cpp/src/tests/sasl_fed_ex_route_cluster b/qpid/cpp/src/tests/sasl_fed_ex_route_cluster
new file mode 100755
index 0000000000..fd59680b6e
--- /dev/null
+++ b/qpid/cpp/src/tests/sasl_fed_ex_route_cluster
@@ -0,0 +1,27 @@
+#! /bin/bash
+
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+
+source ./test_env.sh
+
+${srcdir}/sasl_fed_ex route cluster
+
+