summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2009-07-13 21:29:20 +0000
committerStephen D. Huston <shuston@apache.org>2009-07-13 21:29:20 +0000
commitf61a0c8edb33657fe5067952e085c8b5009a5595 (patch)
treeeeb141ac77043e8743b626142b794fc25de7407c
parentf05c689c4e638078bdd47d3b890b3db53db8dec4 (diff)
downloadqpid-python-f61a0c8edb33657fe5067952e085c8b5009a5595.tar.gz
Add missing externs for Queue methods; silence getenv() warnings on Windows by setting _CRT_NO_SECURE_WARNING
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@793717 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/qpid/broker/Queue.h4
-rw-r--r--qpid/cpp/src/tests/CMakeLists.txt4
2 files changed, 5 insertions, 3 deletions
diff --git a/qpid/cpp/src/qpid/broker/Queue.h b/qpid/cpp/src/qpid/broker/Queue.h
index f1a2afe3a4..777ef5e35a 100644
--- a/qpid/cpp/src/qpid/broker/Queue.h
+++ b/qpid/cpp/src/qpid/broker/Queue.h
@@ -203,11 +203,11 @@ namespace qpid {
* available it will be dispatched immediately, else it
* will be returned to the front of the queue.
*/
- void requeue(const QueuedMessage& msg);
+ QPID_BROKER_EXTERN void requeue(const QueuedMessage& msg);
/**
* Used during recovery to add stored messages back to the queue
*/
- void recover(boost::intrusive_ptr<Message>& msg);
+ QPID_BROKER_EXTERN void recover(boost::intrusive_ptr<Message>& msg);
QPID_BROKER_EXTERN void consume(Consumer::shared_ptr c,
bool exclusive = false);
diff --git a/qpid/cpp/src/tests/CMakeLists.txt b/qpid/cpp/src/tests/CMakeLists.txt
index c8c2fba8c6..34f5d35a9a 100644
--- a/qpid/cpp/src/tests/CMakeLists.txt
+++ b/qpid/cpp/src/tests/CMakeLists.txt
@@ -44,8 +44,10 @@ endif (ENABLE_VALGRIND)
# (non dll-interface class used as base for dll-interface class).
# This is ok, so suppress the warning.
# Also, boost lengthy names trigger warning 4503, decorated name length exceeded
+# and using getenv() triggers insecure CRT warnings which we can silence in the
+# test environment.
if (MSVC)
- add_definitions( /wd4275 /wd4503 )
+ add_definitions( /wd4275 /wd4503 /D_CRT_SECURE_NO_WARNINGS)
endif (MSVC)
# Like this to work with cmake 2.4 on Unix