summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKim van der Riet <kpvdr@apache.org>2009-07-16 17:18:09 +0000
committerKim van der Riet <kpvdr@apache.org>2009-07-16 17:18:09 +0000
commitfc7836dcd8545979f0f65d5b4c8344fa0d17ed6f (patch)
tree2b15bb7fe8509768ef9f7cffaa5f67812e40515d
parentf12e89da3e2401c3db39b8ea50cf54db998b3a74 (diff)
downloadqpid-python-fc7836dcd8545979f0f65d5b4c8344fa0d17ed6f.tar.gz
Minor configure.ac cleanup to remove unneeded openais definitions when no openais is in use.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@794759 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/Makefile.am5
-rw-r--r--qpid/cpp/configure.ac3
2 files changed, 5 insertions, 3 deletions
diff --git a/qpid/cpp/Makefile.am b/qpid/cpp/Makefile.am
index dd67bb8036..2b207f10e8 100644
--- a/qpid/cpp/Makefile.am
+++ b/qpid/cpp/Makefile.am
@@ -17,6 +17,8 @@
# under the License.
#
+LIBTOOL_DEPS = @LIBTOOL_DEPS@
+
AUTOMAKE_OPTIONS = 1.9.2 foreign
ACLOCAL_AMFLAGS = -I m4
@@ -29,6 +31,3 @@ SUBDIRS = managementgen etc src docs/api docs/man examples bindings/qmf
# Update libtool, if needed.
libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status --recheck
-
-
-
diff --git a/qpid/cpp/configure.ac b/qpid/cpp/configure.ac
index 4ee94d27dd..8ce66cf743 100644
--- a/qpid/cpp/configure.ac
+++ b/qpid/cpp/configure.ac
@@ -253,6 +253,7 @@ AC_CHECK_HEADERS([boost/shared_ptr.hpp uuid/uuid.h],,
# Check for optional cluster requirements.
tmp_LIBS=$LIBS
+tmp_LDFLAGS=$LDFLAGS
LDFLAGS="$LDFLAGS -L/usr/lib/openais -L/usr/lib64/openais -L/usr/lib/corosync -L/usr/lib64/corosync"
AC_CHECK_LIB([cpg],[cpg_local_get],[have_libcpg=yes],)
AC_CHECK_HEADERS([openais/cpg.h corosync/cpg.h],[have_cpg_h=yes],)
@@ -272,6 +273,8 @@ AC_ARG_WITH([cpg],
]
)
AM_CONDITIONAL([HAVE_LIBCPG], [test x$with_cpg = xyes])
+# Clean up unnceccassary flags if we don't use clustering
+AS_IF([test ! x$with_cpg = xyes], [LDFLAGS=$tmp_LDFLAGS])
AC_CHECK_LIB([cman],[cman_is_quorate],have_libcman=yes,)
AC_CHECK_HEADERS([libcman.h],have_libcman_h=yes,)