summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2014-01-24 19:40:19 +0000
committerAndrew Stitcher <astitcher@apache.org>2014-01-24 19:40:19 +0000
commitea2a45285fb83554df1364428075cda763644749 (patch)
tree07f5d23b2736dbd34bffe1b1030820ad89c6cf0c
parenta7a46603638c7594c83ad4cbf38860f1e2389070 (diff)
downloadqpid-python-ea2a45285fb83554df1364428075cda763644749.tar.gz
NO-JIRA: Make the python test install depend on the python files.
- So just after the previous checkin Gordon changed the python code. This made me think that the python install needs to have the dependencies! git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1561130 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/tests/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/qpid/cpp/src/tests/CMakeLists.txt b/qpid/cpp/src/tests/CMakeLists.txt
index 74a3463920..a4093c82a2 100644
--- a/qpid/cpp/src/tests/CMakeLists.txt
+++ b/qpid/cpp/src/tests/CMakeLists.txt
@@ -307,10 +307,13 @@ endif (BUILD_SASL)
set (python_bld ${CMAKE_CURRENT_BINARY_DIR}/python)
set (python_src ${CMAKE_SOURCE_DIR}/../python)
-# If we want this to automatically run when we change the python library we will need to
-# add some explicit dependencies on the source python files
+# This will not pick up added or deleted python files
+# In that case you need to rerun CMake
+file(GLOB_RECURSE python_files ${python_src}/*.py)
+
add_custom_command(
OUTPUT ${python_bld}
+ DEPENDS ${python_files}
COMMAND ${PYTHON_EXECUTABLE}
setup.py
build --build-base=${python_bld}/build