summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2013-06-14 22:17:05 +0000
committerAndrew Stitcher <astitcher@apache.org>2013-06-14 22:17:05 +0000
commit7a6d5b0de888e6737a8dd7dfcd6c1b0c8d9b2860 (patch)
tree625d4710c5251666f350ccc7614d0fdacfdac646
parent72a2924a6d8a74528450c1b659ed58d74b1b9f53 (diff)
downloadqpid-python-7a6d5b0de888e6737a8dd7dfcd6c1b0c8d9b2860.tar.gz
QPID-4926: Add in tests missing from the cmake build
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@1493264 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/src/tests/CMakeLists.txt20
1 files changed, 15 insertions, 5 deletions
diff --git a/cpp/src/tests/CMakeLists.txt b/cpp/src/tests/CMakeLists.txt
index a15d9223bf..869ed08722 100644
--- a/cpp/src/tests/CMakeLists.txt
+++ b/cpp/src/tests/CMakeLists.txt
@@ -314,6 +314,15 @@ endif (CMAKE_SYSTEM_NAME STREQUAL Windows)
set(test_wrap ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_test${test_script_suffix})
add_test (unit_test ${test_wrap} ${unit_test_LOCATION})
+add_test (sasl_fed ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/sasl_fed${test_script_suffix})
+add_test (sasl_fed_ex_dynamic ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/sasl_fed_ex_dynamic${test_script_suffix})
+add_test (sasl_fed_ex_link ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/sasl_fed_ex_link${test_script_suffix})
+add_test (sasl_fed_ex_queue ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/sasl_fed_ex_queue${test_script_suffix})
+add_test (sasl_fed_ex_route ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/sasl_fed_ex_route${test_script_suffix})
+add_test (sasl_no_dir ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/sasl_no_dir${test_script_suffix})
+if (BUILD_SSL)
+ add_test(ssl_test ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/ssl_test${test_script_suffix})
+endif (BUILD_SSL)
add_test (start_broker ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/start_broker${test_script_suffix})
add_test (qpid-client-test ${test_wrap} ${qpid-client-test_LOCATION})
add_test (quick_perftest ${test_wrap} ${qpid-perftest_LOCATION} --summary --count 100)
@@ -323,6 +332,7 @@ if (NOT CMAKE_SYSTEM_NAME STREQUAL Windows)
# paged queue not yet implemented for windows
add_test (paged_queue_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_paged_queue_tests${test_script_suffix})
endif (NOT CMAKE_SYSTEM_NAME STREQUAL Windows)
+add_test (msg_group_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_msg_group_tests${test_script_suffix})
if (PYTHON_EXECUTABLE)
add_test (run_header_test ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_header_test${test_script_suffix})
add_test (python_tests ${test_wrap} ${CMAKE_CURRENT_SOURCE_DIR}/python_tests${test_script_suffix})
@@ -334,10 +344,11 @@ if (PYTHON_EXECUTABLE)
if (BUILD_AMQP)
add_test (interlink_tests ${test_wrap} ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/interlink_tests.py)
endif (BUILD_AMQP)
- add_test (ipv6_test ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/ipv6_test${test_script_suffix})
- add_test (federation_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_federation_tests${test_script_suffix})
- add_test (federation_sys_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_federation_sys_tests${test_script_suffix})
- add_test (queue_flow_limit_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_queue_flow_limit_tests${test_script_suffix})
+endif (PYTHON_EXECUTABLE)
+add_test (ipv6_test ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/ipv6_test${test_script_suffix})
+add_test (federation_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_federation_tests${test_script_suffix})
+add_test (federation_sys_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_federation_sys_tests${test_script_suffix})
+add_test (queue_flow_limit_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_queue_flow_limit_tests${test_script_suffix})
if (BUILD_ACL)
add_test (acl_tests ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_acl_tests${test_script_suffix})
endif (BUILD_ACL)
@@ -350,7 +361,6 @@ if (BUILD_MSCLFS)
add_test (store_tests_clfs ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_store_tests${test_script_suffix} MSSQL-CLFS)
endif (BUILD_MSCLFS)
add_test (queue_redirect ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_queue_redirect${test_script_suffix})
-endif (PYTHON_EXECUTABLE)
add_library(test_store MODULE test_store.cpp)
target_link_libraries (test_store qpidbroker qpidcommon)