summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2013-05-29 14:33:05 +0000
committerAlan Conway <aconway@apache.org>2013-05-29 14:33:05 +0000
commit9ebce34a10a67449e047ad3c76d839df1074dce7 (patch)
treec27a9a131b94ad0ca9b1cf61abd1b9a296d08124
parentb93887ed1155d22ac4330a063ac4cfde27fed0f5 (diff)
downloadqpid-python-9ebce34a10a67449e047ad3c76d839df1074dce7.tar.gz
NO-JIRA: CMake: Added missing test_wrap around stop_broker test.
The stop_broker test was being run without the test_wrap wrapper. That meant it was loading the default /etc/qpidd.conf, so the test would fail if that config had any options defined by a module (since the tests dont load default modules.) git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk/qpid@1487501 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/src/tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpp/src/tests/CMakeLists.txt b/cpp/src/tests/CMakeLists.txt
index af96944b2d..a15d9223bf 100644
--- a/cpp/src/tests/CMakeLists.txt
+++ b/cpp/src/tests/CMakeLists.txt
@@ -327,7 +327,7 @@ if (PYTHON_EXECUTABLE)
add_test (run_header_test ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/run_header_test${test_script_suffix})
add_test (python_tests ${test_wrap} ${CMAKE_CURRENT_SOURCE_DIR}/python_tests${test_script_suffix})
endif (PYTHON_EXECUTABLE)
-add_test (stop_broker ${shell} ${CMAKE_CURRENT_SOURCE_DIR}/stop_broker${test_script_suffix})
+add_test (stop_broker ${test_wrap} ${CMAKE_CURRENT_SOURCE_DIR}/stop_broker${test_script_suffix})
if (PYTHON_EXECUTABLE)
add_test (ha_tests ${test_wrap} ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/ha_tests.py)
add_test (qpidd_qmfv2_tests ${test_wrap} ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/qpidd_qmfv2_tests.py)