summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2012-06-22 20:07:19 +0000
committerAlan Conway <aconway@apache.org>2012-06-22 20:07:19 +0000
commit186161dbd8137e905253a4a194254a0a226c32fd (patch)
tree1d9289a565d0c967cf827c928b17c294e7418591
parentba8f39a8b818af7773bbdda6a021a4bb8aa4459c (diff)
downloadqpid-python-186161dbd8137e905253a4a194254a0a226c32fd.tar.gz
NO-JIRA: Trivial code cleanup, removing outdated FIXME comments.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1353017 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt1
-rw-r--r--qpid/cpp/src/ha.mk1
-rw-r--r--qpid/cpp/src/qpid/ha/BackupConnectionExcluder.h1
-rw-r--r--qpid/cpp/src/qpid/ha/BrokerReplicator.cpp3
-rw-r--r--qpid/cpp/src/qpid/ha/ConnectionObserver.cpp1
-rw-r--r--qpid/cpp/src/qpid/ha/PrimaryConnectionMonitor.h61
-rw-r--r--qpid/cpp/src/qpid/ha/QueueReplicator.cpp2
-rw-r--r--qpid/cpp/src/qpid/ha/RemoteBackup.cpp1
8 files changed, 2 insertions, 69 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index cb037573a1..a9b2c6bdb2 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -647,7 +647,6 @@ if (BUILD_HA)
qpid/ha/Membership.h
qpid/ha/Primary.cpp
qpid/ha/Primary.h
- qpid/ha/PrimaryConnectionMonitor.h
qpid/ha/QueueRange.h
qpid/ha/QueueReplicator.cpp
qpid/ha/QueueReplicator.h
diff --git a/qpid/cpp/src/ha.mk b/qpid/cpp/src/ha.mk
index bf1bd10256..ad41db9b0e 100644
--- a/qpid/cpp/src/ha.mk
+++ b/qpid/cpp/src/ha.mk
@@ -40,7 +40,6 @@ ha_la_SOURCES = \
qpid/ha/Membership.h \
qpid/ha/Primary.cpp \
qpid/ha/Primary.h \
- qpid/ha/PrimaryConnectionMonitor.h \
qpid/ha/QueueGuard.cpp \
qpid/ha/QueueGuard.h \
qpid/ha/QueueRange.h \
diff --git a/qpid/cpp/src/qpid/ha/BackupConnectionExcluder.h b/qpid/cpp/src/qpid/ha/BackupConnectionExcluder.h
index 0c66597961..2b7ddef3f1 100644
--- a/qpid/cpp/src/qpid/ha/BackupConnectionExcluder.h
+++ b/qpid/cpp/src/qpid/ha/BackupConnectionExcluder.h
@@ -28,7 +28,6 @@
namespace qpid {
namespace ha {
-// FIXME aconway 2012-06-06: move to Backup.cpp
/**
* Exclude connections to a backup broker.
diff --git a/qpid/cpp/src/qpid/ha/BrokerReplicator.cpp b/qpid/cpp/src/qpid/ha/BrokerReplicator.cpp
index c3521162a1..83c2eaa144 100644
--- a/qpid/cpp/src/qpid/ha/BrokerReplicator.cpp
+++ b/qpid/cpp/src/qpid/ha/BrokerReplicator.cpp
@@ -198,8 +198,7 @@ void BrokerReplicator::initialize() {
);
}
-// FIXME aconway 2012-05-07: reference cycled between Link and BrokerReplicator.
-BrokerReplicator::~BrokerReplicator() { link->close(); }
+BrokerReplicator::~BrokerReplicator() { }
// This is called in the connection IO thread when the bridge is started.
void BrokerReplicator::initializeBridge(Bridge& bridge, SessionHandler& sessionHandler) {
diff --git a/qpid/cpp/src/qpid/ha/ConnectionObserver.cpp b/qpid/cpp/src/qpid/ha/ConnectionObserver.cpp
index f666aa85a6..a5bacd5e31 100644
--- a/qpid/cpp/src/qpid/ha/ConnectionObserver.cpp
+++ b/qpid/cpp/src/qpid/ha/ConnectionObserver.cpp
@@ -32,7 +32,6 @@ namespace ha {
ConnectionObserver::ConnectionObserver(HaBroker& hb, const types::Uuid& uuid)
: haBroker(hb), logPrefix("Connections: "), self(uuid) {}
-// FIXME aconway 2012-06-06: move to BrokerInfo
bool ConnectionObserver::getBrokerInfo(broker::Connection& connection, BrokerInfo& info) {
framing::FieldTable ft;
if (connection.getClientProperties().getTable(ConnectionObserver::BACKUP_TAG, ft)) {
diff --git a/qpid/cpp/src/qpid/ha/PrimaryConnectionMonitor.h b/qpid/cpp/src/qpid/ha/PrimaryConnectionMonitor.h
deleted file mode 100644
index b453d64ae6..0000000000
--- a/qpid/cpp/src/qpid/ha/PrimaryConnectionMonitor.h
+++ /dev/null
@@ -1,61 +0,0 @@
-#ifndef QPID_HA_PRIMARYCONNECTIONOBSERVER_H
-#define QPID_HA_PRIMARYCONNECTIONOBSERVER_H
-
-/*
- *
- * Licensed to the Apache Software Foundation (ASF) under one
- * or more contributor license agreements. See the NOTICE file
- * distributed with this work for additional information
- * regarding copyright ownership. The ASF licenses this file
- * to you under the Apache License, Version 2.0 (the
- * "License"); you may not use this file except in compliance
- * with the License. You may obtain a copy of the License at
- *
- * http://www.apache.org/licenses/LICENSE-2.0
- *
- * Unless required by applicable law or agreed to in writing,
- * software distributed under the License is distributed on an
- * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- * KIND, either express or implied. See the License for the
- * specific language governing permissions and limitations
- * under the License.
- *
- */
-
-#include "types.h"
-#include "ConnectionObserver.h"
-#include "qpid/broker/ConnectionObserver.h"
-#include "qpid/types/Uuid.h"
-#include "qpid/sys/Mutex.h"
-#include <boost/function.hpp>
-
-namespace qpid {
-
-namespace broker {
-class Connection;
-}
-
-namespace ha {
-class HaBroker;
-
-/**
- * Monitor connections on a primary broker. Update membership and
- * primary readiness.
- *
- * THREAD SAFE: has no state, just mediates between other thread-safe objects.
- */
-// FIXME aconway 2012-06-06: rename observer
-class PrimaryConnectionMonitor : public broker::ConnectionObserver
-{
- public:
- PrimaryConnectionMonitor(Primary& p) : primary(p) {}
- void opened(broker::Connection& connection) { primary.opened(connection); }
- void closed(broker::Connection& connection) { primary.closed(connection); }
-
- private:
- Primary& primary;
-};
-
-}} // namespace qpid::ha
-
-#endif /*!QPID_HA_PRIMARYCONNECTIONOBSERVER_H*/
diff --git a/qpid/cpp/src/qpid/ha/QueueReplicator.cpp b/qpid/cpp/src/qpid/ha/QueueReplicator.cpp
index c696050c12..dbed7e1537 100644
--- a/qpid/cpp/src/qpid/ha/QueueReplicator.cpp
+++ b/qpid/cpp/src/qpid/ha/QueueReplicator.cpp
@@ -160,7 +160,7 @@ void QueueReplicator::route(Deliverable& msg)
sys::Mutex::ScopedLock l(lock);
if (!isEventKey(key)) {
msg.deliverTo(queue);
- // FIXME aconway 2012-06-10: race, position may have moved
+ // We are on a backup so the queue is not modified except via this.
QPID_LOG(trace, logPrefix << "Enqueued message " << queue->getPosition());
}
else if (key == DEQUEUE_EVENT_KEY) {
diff --git a/qpid/cpp/src/qpid/ha/RemoteBackup.cpp b/qpid/cpp/src/qpid/ha/RemoteBackup.cpp
index 443c5b0315..7e65b287b0 100644
--- a/qpid/cpp/src/qpid/ha/RemoteBackup.cpp
+++ b/qpid/cpp/src/qpid/ha/RemoteBackup.cpp
@@ -36,7 +36,6 @@ RemoteBackup::RemoteBackup(
createGuards(cg)
{
QPID_LOG(debug, logPrefix << "Guarding queues for backup broker.");
- // FIXME aconway 2012-06-12: potential deadlocks, this is called inside ConnectionObserver::opened.
broker.getQueues().eachQueue(boost::bind(&RemoteBackup::initialQueue, this, _1));
}