summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2006-12-04 16:55:45 +0000
committerAlan Conway <aconway@apache.org>2006-12-04 16:55:45 +0000
commit492e70943188ede4e37701b0630924cf51d792b7 (patch)
tree0f7b7d293a90fc7d6cc7658cf7647be2fc4c0a17
parentf060abcfc156a687115bb218fe37147365b61763 (diff)
downloadqpid-python-492e70943188ede4e37701b0630924cf51d792b7.tar.gz
2006-12-04 Jim Meyering <jim@meyering.net>
* configure.ac: Check for cppunit (>= 1.11.4). Set/substitute CPPUNIT_CXXFLAGS. * tests/Makefile.am (extra_libs): Use $(CPPUNIT_LIBS), rather than hard-coding -lcppunit. (AM_CXXFLAGS): Add $(CPPUNIT_CXXFLAGS). git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid@482252 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/configure.ac5
-rw-r--r--cpp/tests/Makefile.am6
2 files changed, 6 insertions, 5 deletions
diff --git a/cpp/configure.ac b/cpp/configure.ac
index 95aeadf7e0..955c114a7e 100644
--- a/cpp/configure.ac
+++ b/cpp/configure.ac
@@ -85,8 +85,11 @@ PKG_CHECK_MODULES([APR], [apr-1 >= $APR_MINIMUM_VERSION])
APR_CXXFLAGS="$APR_CFLAGS -DUSE_APR=1"
AC_SUBST(APR_CXXFLAGS)
-AC_SUBST(APR_LIBS)
+CPPUNIT_MINIMUM_VERSION=1.11.4
+PKG_CHECK_MODULES([CPPUNIT], [cppunit >= $CPPUNIT_MINIMUM_VERSION])
+CPPUNIT_CXXFLAGS=$CPPUNIT_CFLAGS
+AC_SUBST(CPPUNIT_CXXFLAGS)
AC_CONFIG_FILES([
Makefile
diff --git a/cpp/tests/Makefile.am b/cpp/tests/Makefile.am
index 55c190600f..d5cd60a831 100644
--- a/cpp/tests/Makefile.am
+++ b/cpp/tests/Makefile.am
@@ -1,4 +1,4 @@
-AM_CXXFLAGS = $(WARNING_CFLAGS)
+AM_CXXFLAGS = $(WARNING_CFLAGS) $(CPPUNIT_CXXFLAGS)
INCLUDES = \
-I$(top_srcdir)/gen \
-I$(top_srcdir)/lib \
@@ -9,8 +9,6 @@ INCLUDES = \
-I$(top_srcdir)/lib/common/framing \
$(APR_CXXFLAGS)
-# FIXME: -lcppunit must come from autoconf
-
# FIXME: have e.g., topicall, run as part of "make check"?
EXTRA_DIST = \
env \
@@ -80,7 +78,7 @@ run-python-tests: $(check_LTLIBRARIES)
include gen.mk
abs_builddir = @abs_builddir@
-extra_libs = -lcppunit
+extra_libs = $(CPPUNIT_LIBS)
lib_client = $(abs_builddir)/../lib/client/libclient.la
lib_common = $(abs_builddir)/../lib/common/libcommon.la
lib_broker = $(abs_builddir)/../lib/broker/libbroker.la