summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Sim <gsim@apache.org>2006-12-05 13:12:25 +0000
committerGordon Sim <gsim@apache.org>2006-12-05 13:12:25 +0000
commit7107d5c1c3c8323d832184fc097a5d9223633d32 (patch)
treecae2a1c7a8b55f89eaee6a1384ef4243369d5581
parent38700954419b292cbfc79e443e9583d033d1af3a (diff)
downloadqpid-python-7107d5c1c3c8323d832184fc097a5d9223633d32.tar.gz
Patch submitted on qpid-dev:
2006-12-05 Jim Meyering <meyering@redhat.com> * gen/Makefile.am (timestamp): Remove unnecessary "; \", that could have obscured a failure. (gen-src.mk): Use echo 'var = '\\, rather than 'var = \'. Both work, but emacs' font-lock mode mishandles the latter. * bootstrap: Give JAVA and JAVAC default values, and export them. Don't define abs_srcdir; no longer needed. Also filter out gen/Makefile.am's echo warning: ... Add comments. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid@482637 13f79535-47bb-0310-9956-ffa450edef68
-rwxr-xr-xcpp/bootstrap13
-rw-r--r--cpp/gen/Makefile.am12
2 files changed, 17 insertions, 8 deletions
diff --git a/cpp/bootstrap b/cpp/bootstrap
index 34b16cb16b..e52b403700 100755
--- a/cpp/bootstrap
+++ b/cpp/bootstrap
@@ -4,13 +4,22 @@ aclocal -I m4
autoheader
libtoolize --automake
+# These are needed only if you don't already have the gen/*.{h,cpp} files.
+: ${JAVA=java}
+: ${JAVAC=javac}
+export JAVA JAVAC
+
# If we're building in the qpid tree, we can generate
# some Makefile snippets:
if test -d ../gentools && test -d ../specs; then
+ # Transform gen/Makefile.am, removing automake-constructs and the
+ # contents of the sole automake-else clause (the warning), then
+ # use the result to run the rules that create gen-src.mk, a file
+ # that must be created before we run automake.
(cd gen && rm -f gen-src.mk
- perl -ne '/^(abs_srcdir|if|else|endif|include)\b/ or print' Makefile.am \
- | make -f - abs_srcdir=`pwd` srcdir=. gen-src.mk > /dev/null )
+ perl -ne '/warning:|^(if|else|endif|include)\b/ or print' Makefile.am \
+ | make -f - srcdir=. gen-src.mk > /dev/null )
fi
# Generate (for automake) lots of repetitive parts of tests/Makefile.am.
diff --git a/cpp/gen/Makefile.am b/cpp/gen/Makefile.am
index 0529afbf7e..eea08c9570 100644
--- a/cpp/gen/Makefile.am
+++ b/cpp/gen/Makefile.am
@@ -15,9 +15,9 @@ gentools_srcdir = $(gentools_dir)/src/org/apache/qpid/gentools
timestamp: $(spec) $(java_sources) $(cxx_templates)
if BUILD_IN_MESSAGE_TREE
rm -f $(generated_sources)
- (cd $(gentools_srcdir) && rm -f *.class && $(JAVAC) *.java); \
- $(JAVA) -cp $(gentools_dir)/src org.apache.qpid.gentools.Main \
- -c -o . -t $(gentools_dir)/templ.cpp $(spec)
+ cd $(gentools_srcdir) && rm -f *.class && $(JAVAC) *.java
+ $(JAVA) -cp $(gentools_dir)/src org.apache.qpid.gentools.Main \
+ -c -o . -t $(gentools_dir)/templ.cpp $(spec)
else
echo "warning: failed to regenerate gen/*.{cpp,h}" 1>&2
endif
@@ -28,15 +28,15 @@ $(generated_sources): timestamp
DISTCLEANFILES = gen-src.mk
gen-src.mk: timestamp
- ( echo 'generated_sources = \' \
+ ( echo 'generated_sources = '\\ \
&& ls *.cpp *.h | sort -u | sed 's/.*/ & \\/;$$s/ \\//' \
) > $@-t
if BUILD_IN_MESSAGE_TREE
( echo if BUILD_IN_MESSAGE_TREE; \
- echo 'java_sources = \' \
+ echo 'java_sources = '\\ \
&& find $(gentools_srcdir) -name '*.java' \
| sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
- echo 'cxx_templates = \' \
+ echo 'cxx_templates = '\\ \
&& find $(gentools_dir)/templ.cpp -name '*.tmpl' \
| sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
echo endif \