summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2006-12-04 21:33:33 +0000
committerAlan Conway <aconway@apache.org>2006-12-04 21:33:33 +0000
commit8869364b421d17ec36e2820cd506b298f7dadde4 (patch)
tree13f18fc9afccd1c3e263f551810d4d6a47200faa
parent35508e78dc4ad9a29e187eb125326e79381bf45b (diff)
downloadqpid-python-8869364b421d17ec36e2820cd506b298f7dadde4.tar.gz
2006-12-04 Jim Meyering <jim@meyering.net>
Changes to make "make distcheck" pass. * gen/Makefile.am (DISTCLEANFILES): List gen-src.mk here, rather than distributing it. (gen-src.mk): Guard emitted java_sources and cxx_templates templates with "if BUILD_IN_MESSAGE_TREE" conditional. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk/qpid@482367 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--cpp/gen/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/cpp/gen/Makefile.am b/cpp/gen/Makefile.am
index 8c179dfd06..0529afbf7e 100644
--- a/cpp/gen/Makefile.am
+++ b/cpp/gen/Makefile.am
@@ -26,19 +26,20 @@ endif
EXTRA_DIST += timestamp
$(generated_sources): timestamp
-EXTRA_DIST += gen-src.mk
+DISTCLEANFILES = gen-src.mk
gen-src.mk: timestamp
( echo 'generated_sources = \' \
&& ls *.cpp *.h | sort -u | sed 's/.*/ & \\/;$$s/ \\//' \
) > $@-t
if BUILD_IN_MESSAGE_TREE
- ( echo 'java_sources = \' \
+ ( echo if BUILD_IN_MESSAGE_TREE; \
+ echo 'java_sources = \' \
&& find $(gentools_srcdir) -name '*.java' \
- | sort -u | sed 's/.*/ & \\/;$$s/ \\//' \
- ) >> $@-t
- ( echo 'cxx_templates = \' \
+ | sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
+ echo 'cxx_templates = \' \
&& find $(gentools_dir)/templ.cpp -name '*.tmpl' \
- | sort -u | sed 's/.*/ & \\/;$$s/ \\//' \
+ | sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
+ echo endif \
) >> $@-t
endif
mv $@-t $@