summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Teira Paz <mteira@apache.org>2009-06-10 06:49:26 +0000
committerManuel Teira Paz <mteira@apache.org>2009-06-10 06:49:26 +0000
commit3a9ab627b39b4fe2ab515e27dc162d12d0744777 (patch)
tree4651135dbfe8424ef9c95ae60ddbf543109e309b
parentc0ba90556821265cc6e5404d817ecfea3f3e21cd (diff)
downloadqpid-python-3a9ab627b39b4fe2ab515e27dc162d12d0744777.tar.gz
cpp/src/replication.mk
- Avoid explicit linkage with -lCrun. Use SUNCC_RUNTIME_FLAGS that would be conditionally replaced with -lCrun for the Sun Studio Compiler git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@783231 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/replication.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/qpid/cpp/src/replication.mk b/qpid/cpp/src/replication.mk
index c65a7ae3b9..4a51fb9c7d 100644
--- a/qpid/cpp/src/replication.mk
+++ b/qpid/cpp/src/replication.mk
@@ -47,6 +47,6 @@ replication_exchange_la_SOURCES = \
replication_exchange_la_LIBADD = libqpidbroker.la
if SUNOS
- replication_exchange_la_LIBADD += libqpidcommon.la -lboost_program_options -lCrun -luuid
+ replication_exchange_la_LIBADD += libqpidcommon.la -lboost_program_options $(SUNCC_RUNTIME_LIBS) -luuid
endif
replication_exchange_la_LDFLAGS = $(PLUGINLDFLAGS)