summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2008-08-18 18:52:39 +0000
committerAlan Conway <aconway@apache.org>2008-08-18 18:52:39 +0000
commitf6b0fd103342ad154a85d875262001a06d93097e (patch)
tree87def175a5ef055b3f1697f5c29d748eca250331
parent40df26dd75d7096006bd4cf7a11ecfd8eca327be (diff)
downloadqpid-python-f6b0fd103342ad154a85d875262001a06d93097e.tar.gz
Configure --without-cpg by default for M3.
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@686846 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/qpid/cpp/configure.ac b/qpid/cpp/configure.ac
index 1aa0a6fe63..5e478c68cf 100644
--- a/qpid/cpp/configure.ac
+++ b/qpid/cpp/configure.ac
@@ -175,14 +175,12 @@ AC_ARG_WITH([cpg],
no) with_CPG=no ;;
*) AC_MSG_ERROR([Bad value ${withval} for --with-cpg option]) ;;
esac],
- [ # not specified - enable if libs/headers available.
- with_CPG=yes
- AC_CHECK_LIB([cpg],[cpg_local_get],,[with_CPG=no])
- AC_CHECK_HEADERS([openais/cpg.h],,[with_CPG=no])
+ [ # not specified - default no
+ with_CPG=no
]
)
-# Remove from LIBS, we will link it explicitly in make files.
LIBS=$tmp_LIBS
+
AM_CONDITIONAL([CPG], [test x$with_CPG = xyes])
if test x$with_CPG = xyes; then
CPPFLAGS+=" -DCPG"