summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-01-25 16:45:48 +0000
committerAlan Conway <aconway@apache.org>2007-01-25 16:45:48 +0000
commit2d413a6c742cd84740ce7f96219af401a25a9d91 (patch)
tree5adcaccccd9e791768d659f189740d2b1864f41c
parenta1a920a608fca9ba42020b699dceef9da002eef2 (diff)
downloadqpid-python-2d413a6c742cd84740ce7f96219af401a25a9d91.tar.gz
* qpidc.spec.in: updated to release 3 for RPM.
* gen/make-gen-src-mk.sh: fixed problem with makefile generation in a new checkout. * Other Makefile.am: added missing files to maintainer-clean. * Added missing svn-ignores. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@499845 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/gen/Makefile.am23
-rwxr-xr-xqpid/cpp/gen/make-gen-src-mk.sh30
-rw-r--r--qpid/cpp/qpidc.spec.in5
-rw-r--r--qpid/cpp/rpm/Makefile.am5
-rw-r--r--qpid/cpp/tests/Makefile.am3
5 files changed, 42 insertions, 24 deletions
diff --git a/qpid/cpp/gen/Makefile.am b/qpid/cpp/gen/Makefile.am
index 5d9473f615..e1707b86c4 100644
--- a/qpid/cpp/gen/Makefile.am
+++ b/qpid/cpp/gen/Makefile.am
@@ -6,7 +6,7 @@ pkginclude_HEADERS=$(generated_headers)
# Distribute the generated sources, at least for now, since
# the generator code is in java.
EXTRA_DIST = $(BUILT_SOURCES)
-MAINTAINERCLEANFILES = $(BUILT_SOURCES)
+DISTCLEANFILES = $(BUILT_SOURCES) timestamp gen-src.mk
# Don't attempt to run the code generator unless configure has set
# CAN_GENERATE_CODE, indicating that the amqp.xml and tools needed
@@ -26,26 +26,7 @@ $(BUILT_SOURCES) timestamp: $(spec) $(java_sources) $(cxx_templates)
-c -o . -t $(gentools_dir)/templ.cpp $(spec)
touch timestamp
-DISTCLEANFILES = gen-src.mk
gen-src.mk: timestamp
- ( echo 'generated_sources = '\\ \
- && ls *.cpp | sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
- echo 'generated_headers = '\\ \
- && ls *.h | sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
- ) > $@-t
- ( echo if CAN_GENERATE_CODE; \
- echo 'java_sources = '\\ \
- && find $(gentools_srcdir) -name '*.java' \
- | sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
- echo 'cxx_templates = '\\ \
- && find $(gentools_dir)/templ.cpp -name '*.tmpl' \
- | sort -u | sed 's/.*/ & \\/;$$s/ \\//'; \
- echo '# Empty rules, in case any of these files is removed,'; \
- echo '# renamed, or no longer generated.'; \
- echo '$$(spec):'; \
- echo '$$(java_sources):'; \
- echo '$$(cxx_templates):'; \
- echo endif \
- ) >> $@-t
+ ./make-gen-src-mk.sh $(gentools_dir) $(gentools_srcdir) >> $@-t
mv $@-t $@
endif
diff --git a/qpid/cpp/gen/make-gen-src-mk.sh b/qpid/cpp/gen/make-gen-src-mk.sh
new file mode 100755
index 0000000000..08eb8ea134
--- /dev/null
+++ b/qpid/cpp/gen/make-gen-src-mk.sh
@@ -0,0 +1,30 @@
+#!/bin/sh
+# Generate the gen-src.mk makefile fragment, to stdout.
+# Usage: <gentools_dir> <gentools_srcdir>
+
+gentools_dir=$1
+gentools_srcdir=$2
+
+wildcard() { echo `ls $* 2>/dev/null` ; }
+
+cat <<EOF
+generated_sources = `wildcard *.cpp`
+
+generated_headers = `wildcard *.h`
+
+if CAN_GENERATE_CODE
+
+java_sources = `wildcard $gentools_srcdir/*.java`
+
+cxx_templates = `wildcard $gentools_dir/templ.cpp/*.tmpl`
+
+# Empty rules in case one of these files is removed,
+# renamed or no longer generated.
+\$(spec):
+\$(java_sources):
+\$(cxx_templates):
+endif
+
+EOF
+
+
diff --git a/qpid/cpp/qpidc.spec.in b/qpid/cpp/qpidc.spec.in
index fb1cd3cb22..d6d0288d63 100644
--- a/qpid/cpp/qpidc.spec.in
+++ b/qpid/cpp/qpidc.spec.in
@@ -5,7 +5,7 @@
Name: @PACKAGE@
Version: @VERSION@
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Libraries for Qpid C++ client applications
Group: System Environment/Libraries
License: Apache Software License
@@ -137,3 +137,6 @@ fi
* Fri Dec 8 2006 David Lutterkort <dlutter@redhat.com> - 0.1-1
- Initial version based on Jim Meyering's sketch and discussions with Alan
Conway
+
+* Thu Jan 25 Alan Conway <aconway@redhat.com> - 0.1-3
+- Applied Jim Meyereings fixes from http://mail-archives.apache.org/mod_mbox/incubator-qpid-dev/200701.mbox/%3c87hcugzmyp.fsf@rho.meyering.net%3e
diff --git a/qpid/cpp/rpm/Makefile.am b/qpid/cpp/rpm/Makefile.am
index 1a713ee65f..7f3a4b4b6b 100644
--- a/qpid/cpp/rpm/Makefile.am
+++ b/qpid/cpp/rpm/Makefile.am
@@ -14,9 +14,10 @@ clean-local:
# Build source and binary RPMs.
rpm: dist
- rpmbuild $(RPMOPTS) -ba $(SPEC)
+ rpmbuild $(RPMOPTS) $(RPMEXTRAOPTS) -ba $(SPEC)
+ rpmlint RPMS/*.rpm
-# Source RPM only.
+# Build source RPM only.
srpm: dist
rpmbuild $(RPMOPTS) -bs $(SPEC)
diff --git a/qpid/cpp/tests/Makefile.am b/qpid/cpp/tests/Makefile.am
index 7a5f396932..7764d79721 100644
--- a/qpid/cpp/tests/Makefile.am
+++ b/qpid/cpp/tests/Makefile.am
@@ -75,6 +75,9 @@ TESTS_ENVIRONMENT = \
TESTS = run-unit-tests run-python-tests
EXTRA_DIST += $(TESTS)
+CLEANFILES=qpidd.log
+DISTCLEANFILES=gen.mk
+
include gen.mk
abs_builddir = @abs_builddir@