summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Stitcher <astitcher@apache.org>2010-02-17 22:47:37 +0000
committerAndrew Stitcher <astitcher@apache.org>2010-02-17 22:47:37 +0000
commit2de7b8d5009289b273769a50559066661dce90e0 (patch)
treea474865bbdda2fbbdc78cb037433da0a1bca52e2
parent5fb7281ee4a8d0ed5821ed5f0e295ea26dda7ca6 (diff)
downloadqpid-python-2de7b8d5009289b273769a50559066661dce90e0.tar.gz
Allow cmake build to work again with earlier boost versions
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@911207 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index 77a45ec103..62bab239be 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -166,13 +166,14 @@ endif(NOT Boost_FOUND)
# Boost.system was introduced at Boost 1.35; it's needed secondarily by other
# Boost libs Qpid needs, so be sure it's there.
-if (NOT Boost_VERSION LESS 103500)
+if (Boost_VERSION GREATER 103499)
find_package(Boost COMPONENTS system)
+
+ # Allow for cmake pre 2.6 and boost post 1.35
if (NOT Boost_SYSTEM_LIBRARY)
set(Boost_SYSTEM_LIBRARY boost_system)
endif (NOT Boost_SYSTEM_LIBRARY)
-
-endif (NOT Boost_VERSION LESS 103500)
+endif (Boost_VERSION GREATER 103499)
# Versions of cmake pre 2.6 don't set the Boost_*_LIBRARY variables correctly
# these values are correct for Linux
@@ -192,10 +193,6 @@ if (NOT Boost_REGEX_LIBRARY)
set(Boost_REGEX_LIBRARY boost_regex)
endif (NOT Boost_REGEX_LIBRARY)
-if (NOT Boost_SYSTEM_LIBRARY)
- set(Boost_SYSTEM_LIBRARY boost_system)
-endif (NOT Boost_SYSTEM_LIBRARY)
-
# The Windows install also wants the Boost DLLs and headers that the release
# is built with. The DLLs enable everything to run, and the headers ensure
# that users building Qpid C++ client programs can compile (the C++ API