summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2010-02-17 00:18:36 +0000
committerStephen D. Huston <shuston@apache.org>2010-02-17 00:18:36 +0000
commit7b28f2c84eae3186ac17abba64cc0b3d0a1e2828 (patch)
treeae0aeb6769e80c2cd8b4c6dcf1d06028affb5a10
parentaaabede31fc48296076bc57abe07eddcb4fd55d0 (diff)
downloadqpid-python-7b28f2c84eae3186ac17abba64cc0b3d0a1e2828.tar.gz
Build the ACL source into the qpidbroker library on Windows; works around the problems with qmf-gen'd management code; see QPID-1842 for history.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@910782 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt32
1 files changed, 17 insertions, 15 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index f870601da8..77a45ec103 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -357,10 +357,6 @@ endif (BUILD_XML)
# Build the ACL plugin
set (acl_default ON)
-# Like this until we fix exporting symbols from the generated management code
-if (CMAKE_SYSTEM_NAME STREQUAL Windows)
- set(acl_default OFF)
-endif (CMAKE_SYSTEM_NAME STREQUAL Windows)
option(BUILD_ACL "Build ACL enforcement broker plugin" ${acl_default})
if (BUILD_ACL)
set (acl_SOURCES
@@ -372,17 +368,22 @@ if (BUILD_ACL)
qpid/acl/AclReader.cpp
qpid/acl/AclReader.h
)
- add_library (acl MODULE ${acl_SOURCES})
- set_target_properties (acl PROPERTIES PREFIX "")
- target_link_libraries (acl qpidbroker ${Boost_PROGRAM_OPTIONS_LIBRARY})
- if (CMAKE_COMPILER_IS_GNUCXX)
- set_target_properties (acl PROPERTIES
- PREFIX ""
- LINK_FLAGS -Wl,--no-undefined)
- endif (CMAKE_COMPILER_IS_GNUCXX)
- install (TARGETS acl
- DESTINATION ${QPIDD_MODULE_DIR}
- COMPONENT ${QPID_COMPONENT_BROKER})
+ # Windows builds the ACL code into the qpidbroker library; see QPID-1842
+ # for history and rationale. If this is changed, remove the acl_SOURCES from
+ # the qpidbroker platform-specific source list.
+ if (NOT CMAKE_SYSTEM_NAME STREQUAL Windows)
+ add_library (acl MODULE ${acl_SOURCES})
+ set_target_properties (acl PROPERTIES PREFIX "")
+ target_link_libraries (acl qpidbroker ${Boost_PROGRAM_OPTIONS_LIBRARY})
+ if (CMAKE_COMPILER_IS_GNUCXX)
+ set_target_properties (acl PROPERTIES
+ PREFIX ""
+ LINK_FLAGS -Wl,--no-undefined)
+ endif (CMAKE_COMPILER_IS_GNUCXX)
+ install (TARGETS acl
+ DESTINATION ${QPIDD_MODULE_DIR}
+ COMPONENT ${QPID_COMPONENT_BROKER})
+ endif (NOT CMAKE_SYSTEM_NAME STREQUAL Windows)
endif (BUILD_ACL)
# Check for optional cluster support requirements
@@ -439,6 +440,7 @@ if (CMAKE_SYSTEM_NAME STREQUAL Windows)
set (qpidbroker_platform_SOURCES
qpid/broker/windows/BrokerDefaults.cpp
qpid/broker/windows/SaslAuthenticator.cpp
+ ${acl_SOURCES}
${sslbroker_windows_SOURCES}
)
set (qpidbroker_platform_LIBS