summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael H. Schloming <rhs@apache.org>2010-02-18 21:29:59 +0000
committerRafael H. Schloming <rhs@apache.org>2010-02-18 21:29:59 +0000
commit7ce8a5fde128f01c67bbdf638eacedcdd631cc65 (patch)
tree5fbba2708ad5224d06c6cf5192df4a9ef16df98e
parent5b0e6027035122d27a336b9f6b685ede090b58f5 (diff)
downloadqpid-python-7ce8a5fde128f01c67bbdf638eacedcdd631cc65.tar.gz
remove extra dots from filenames so as not to confuse windows
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@911596 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/python/qpid/ops.py3
-rw-r--r--qpid/python/qpid/specs/amqp-0-10-qpid-errata.xml (renamed from qpid/python/qpid/specs/amqp.0-10-qpid-errata.xml)2
-rw-r--r--qpid/python/qpid/specs/amqp-0-10.dtd (renamed from qpid/python/qpid/specs/amqp.0-10.dtd)0
-rw-r--r--qpid/python/qpid/specs/amqp-0-8.xml (renamed from qpid/python/qpid/specs/amqp.0-8.xml)0
-rw-r--r--qpid/python/qpid/specs/amqp-0-9.xml (renamed from qpid/python/qpid/specs/amqp.0-9.xml)0
-rw-r--r--qpid/python/qpid/specs_config.py6
-rwxr-xr-xqpid/python/setup.py11
7 files changed, 13 insertions, 9 deletions
diff --git a/qpid/python/qpid/ops.py b/qpid/python/qpid/ops.py
index ac1819e6da..acb54aedc5 100644
--- a/qpid/python/qpid/ops.py
+++ b/qpid/python/qpid/ops.py
@@ -242,7 +242,8 @@ def load_types_from_xml(file):
return types
def load_types(file):
- pclfile = "%s.ops.pcl" % file
+ base, ext = os.path.splitext(file)
+ pclfile = "%s.pcl" % base
if os.path.exists(pclfile) and \
os.path.getmtime(pclfile) > os.path.getmtime(file):
f = open(pclfile, "rb")
diff --git a/qpid/python/qpid/specs/amqp.0-10-qpid-errata.xml b/qpid/python/qpid/specs/amqp-0-10-qpid-errata.xml
index 365928ea4e..d0d9486fef 100644
--- a/qpid/python/qpid/specs/amqp.0-10-qpid-errata.xml
+++ b/qpid/python/qpid/specs/amqp-0-10-qpid-errata.xml
@@ -121,7 +121,7 @@
-->
-<!DOCTYPE amqp SYSTEM "amqp.0-10.dtd">
+<!DOCTYPE amqp SYSTEM "amqp-0-10.dtd">
<amqp xmlns="http://www.amqp.org/schema/amqp.xsd"
major="0" minor="10" port="5672">
diff --git a/qpid/python/qpid/specs/amqp.0-10.dtd b/qpid/python/qpid/specs/amqp-0-10.dtd
index 2be198525a..2be198525a 100644
--- a/qpid/python/qpid/specs/amqp.0-10.dtd
+++ b/qpid/python/qpid/specs/amqp-0-10.dtd
diff --git a/qpid/python/qpid/specs/amqp.0-8.xml b/qpid/python/qpid/specs/amqp-0-8.xml
index 0463f45fa9..0463f45fa9 100644
--- a/qpid/python/qpid/specs/amqp.0-8.xml
+++ b/qpid/python/qpid/specs/amqp-0-8.xml
diff --git a/qpid/python/qpid/specs/amqp.0-9.xml b/qpid/python/qpid/specs/amqp-0-9.xml
index 73cace7015..73cace7015 100644
--- a/qpid/python/qpid/specs/amqp.0-9.xml
+++ b/qpid/python/qpid/specs/amqp-0-9.xml
diff --git a/qpid/python/qpid/specs_config.py b/qpid/python/qpid/specs_config.py
index 578f141b4e..58021320f6 100644
--- a/qpid/python/qpid/specs_config.py
+++ b/qpid/python/qpid/specs_config.py
@@ -20,6 +20,6 @@
import os
AMQP_SPEC_DIR=os.path.join(os.path.dirname(os.path.abspath(__file__)), "specs")
-amqp_spec = os.path.join(AMQP_SPEC_DIR, "amqp.0-10-qpid-errata.xml")
-amqp_spec_0_8 = os.path.join(AMQP_SPEC_DIR, "amqp.0-8.xml")
-amqp_spec_0_9 = os.path.join(AMQP_SPEC_DIR, "amqp.0-9.xml")
+amqp_spec = os.path.join(AMQP_SPEC_DIR, "amqp-0-10-qpid-errata.xml")
+amqp_spec_0_8 = os.path.join(AMQP_SPEC_DIR, "amqp-0-8.xml")
+amqp_spec_0_9 = os.path.join(AMQP_SPEC_DIR, "amqp-0-9.xml")
diff --git a/qpid/python/setup.py b/qpid/python/setup.py
index cb06444240..bdd04d4ddf 100755
--- a/qpid/python/setup.py
+++ b/qpid/python/setup.py
@@ -270,22 +270,25 @@ class build_py(preprocessor, _build_py):
else:
return None, None
+def pclfile(xmlfile):
+ return "%s.pcl" % os.path.splitext(xmlfile)[0]
+
class install_lib(_install_lib):
def get_outputs(self):
outputs = _install_lib.get_outputs(self)
extra = []
for of in outputs:
- if os.path.basename(of) == "amqp.0-10-qpid-errata.xml":
- extra.append("%s.ops.pcl" % of)
+ if os.path.basename(of) == "amqp-0-10-qpid-errata.xml":
+ extra.append(pclfile(of))
return outputs + extra
def install(self):
outfiles = _install_lib.install(self)
extra = []
for of in outfiles:
- if os.path.basename(of) == "amqp.0-10-qpid-errata.xml":
- tgt = "%s.ops.pcl" % of
+ if os.path.basename(of) == "amqp-0-10-qpid-errata.xml":
+ tgt = pclfile(of)
if self.force or newer(of, tgt):
log.info("caching %s to %s" % (of, os.path.basename(tgt)))
if not self.dry_run: