summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2010-02-19 23:01:17 +0000
committerTed Ross <tross@apache.org>2010-02-19 23:01:17 +0000
commitc1611f64a7c9dce39c19794dd3d887e3f1815b29 (patch)
tree65c72ff60c7000cf3aa9c91871f291a5e0749dae
parent0f485552e3c5c59db7d267dcaf9d371c807443ea (diff)
downloadqpid-python-c1611f64a7c9dce39c19794dd3d887e3f1815b29.tar.gz
Synced the branch with the trunk.
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/qmf-devel0.7@912024 13f79535-47bb-0310-9956-ffa450edef68
-rwxr-xr-xqpid/extras/qmf/setup.py2
-rw-r--r--qpid/python/qpid/messaging/driver.py16
-rw-r--r--qpid/python/qpid/messaging/endpoints.py15
-rwxr-xr-xqpid/tools/setup.py2
4 files changed, 19 insertions, 16 deletions
diff --git a/qpid/extras/qmf/setup.py b/qpid/extras/qmf/setup.py
index b7e47ce135..c7626aa932 100755
--- a/qpid/extras/qmf/setup.py
+++ b/qpid/extras/qmf/setup.py
@@ -21,6 +21,8 @@ from distutils.core import setup
setup(name="qpid-qmf",
version="0.7",
+ author="Apache Qpid",
+ author_email="dev@qpid.apache.org",
packages=["qmf", "qmf2", "qmf2.tests"],
package_dir={"": "src/py"},
url="http://qpid.apache.org/",
diff --git a/qpid/python/qpid/messaging/driver.py b/qpid/python/qpid/messaging/driver.py
index 9d58616804..a09686badd 100644
--- a/qpid/python/qpid/messaging/driver.py
+++ b/qpid/python/qpid/messaging/driver.py
@@ -28,7 +28,6 @@ from qpid.framing import OpEncoder, SegmentEncoder, FrameEncoder, \
FrameDecoder, SegmentDecoder, OpDecoder
from qpid.messaging import address
from qpid.messaging.constants import UNLIMITED
-from qpid.messaging.endpoints import Pattern
from qpid.messaging.exceptions import ConnectError
from qpid.messaging.message import get_codec, Message
from qpid.ops import *
@@ -64,6 +63,21 @@ DURABLE_DEFAULT=True
# XXX
+class Pattern:
+ """
+ The pattern filter matches the supplied wildcard pattern against a
+ message subject.
+ """
+
+ def __init__(self, value):
+ self.value = value
+
+ # XXX: this should become part of the driver
+ def _bind(self, sst, exchange, queue):
+ from qpid.ops import ExchangeBind
+ sst.write_cmd(ExchangeBind(exchange=exchange, queue=queue,
+ binding_key=self.value.replace("*", "#")))
+
FILTER_DEFAULTS = {
"topic": Pattern("*"),
"amq.failover": Pattern("DUMMY")
diff --git a/qpid/python/qpid/messaging/endpoints.py b/qpid/python/qpid/messaging/endpoints.py
index 2337986ecb..596866de66 100644
--- a/qpid/python/qpid/messaging/endpoints.py
+++ b/qpid/python/qpid/messaging/endpoints.py
@@ -191,21 +191,6 @@ class Connection:
ssn.close()
self.disconnect()
-class Pattern:
- """
- The pattern filter matches the supplied wildcard pattern against a
- message subject.
- """
-
- def __init__(self, value):
- self.value = value
-
- # XXX: this should become part of the driver
- def _bind(self, sst, exchange, queue):
- from qpid.ops import ExchangeBind
- sst.write_cmd(ExchangeBind(exchange=exchange, queue=queue,
- binding_key=self.value.replace("*", "#")))
-
class Session:
"""
diff --git a/qpid/tools/setup.py b/qpid/tools/setup.py
index eeabd858ae..1f50428edc 100755
--- a/qpid/tools/setup.py
+++ b/qpid/tools/setup.py
@@ -21,6 +21,8 @@ from distutils.core import setup
setup(name="qpid-tools",
version="0.7",
+ author="Apache Qpid",
+ author_email="dev@qpid.apache.org",
scripts=["src/py/qpid-cluster",
"src/py/qpid-config",
"src/py/qpid-printevents",