summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2010-02-17 00:33:40 +0000
committerStephen D. Huston <shuston@apache.org>2010-02-17 00:33:40 +0000
commite5480f19a47abb914e0e61a8d9a8500f90caebe3 (patch)
treeec9f0c40674cd08e5b198bd577429b4816370e0a
parentd726e4395c9f6b883b5fa469828cd8af1460d6de (diff)
downloadqpid-python-e5480f19a47abb914e0e61a8d9a8500f90caebe3.tar.gz
Comment out the gacutil stuff for the WCF DLLs and explain why. Related to QPID-2310.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@910788 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/CMakeLists.txt25
1 files changed, 17 insertions, 8 deletions
diff --git a/qpid/cpp/CMakeLists.txt b/qpid/cpp/CMakeLists.txt
index 272d007c4a..8c4aa06ee2 100644
--- a/qpid/cpp/CMakeLists.txt
+++ b/qpid/cpp/CMakeLists.txt
@@ -56,14 +56,23 @@ if (WIN32)
COMPONENT ${QPID_COMPONENT_EXAMPLES}
PATTERN ".svn" EXCLUDE)
-set (CPACK_NSIS_EXTRA_INSTALL_COMMANDS "
- ExecWait 'gacutil -I \\\"$INSTDIR\\\\${QPID_INSTALL_LIBDIR}\\\\Apache.Qpid.Channel.dll\\\"'
- ExecWait 'gacutil -I \\\"$INSTDIR\\\\${QPID_INSTALL_LIBDIR}\\\\Apache.Qpid.Interop.dll\\\"'
- ")
-set (CPACK_NSIS_EXTRA_UNINSTALL_COMMANDS "
- ExecWait 'gacutil /u \\\"Apache.Qpid.Channel\\\"'
- ExecWait 'gacutil /u \\\"Apache.Qpid.Interop\\\"'
- ")
+ # Find where gacutil is; it's not usually on the default PATH. If it can't
+ # be located, the WCF assemblies can't be inserted in the GAC.
+ # The gacutil stuff is disabled for now; to re-enable it, one must be able
+ # to either find the gacutil somehow and specify the directory where
+ # gacutil lives, add it to PATH, or use the FUSE API in a program that
+ # inserts the DLLs programatically without gacutil. Or use WiX, which can
+ # supposedly do this in an easier way.
+ #
+ # See jira QPID-2310 for more info; update that if you change this.
+ #set (CPACK_NSIS_EXTRA_INSTALL_COMMANDS "
+ # ExecWait 'gacutil -I \\\"$INSTDIR\\\\${QPID_INSTALL_LIBDIR}\\\\Apache.Qpid.Channel.dll\\\"'
+ # ExecWait 'gacutil -I \\\"$INSTDIR\\\\${QPID_INSTALL_LIBDIR}\\\\Apache.Qpid.Interop.dll\\\"'
+ # ")
+ #set (CPACK_NSIS_EXTRA_UNINSTALL_COMMANDS "
+ # ExecWait 'gacutil /u \\\"Apache.Qpid.Channel\\\"'
+ # ExecWait 'gacutil /u \\\"Apache.Qpid.Interop\\\"'
+ # ")
endif (WIN32)