summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael H. Schloming <rhs@apache.org>2010-03-01 21:03:57 +0000
committerRafael H. Schloming <rhs@apache.org>2010-03-01 21:03:57 +0000
commit50ff3536599511ab7ec3be6756a3a2cb4ed2243e (patch)
tree76ce760d143285da42627dcb275512f9ca34fcb0
parent108546b3000cb0352eaa59adb45c20907b133eba (diff)
downloadqpid-python-50ff3536599511ab7ec3be6756a3a2cb4ed2243e.tar.gz
added setup.py for qpid-tests
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@917717 13f79535-47bb-0310-9956-ffa450edef68
-rwxr-xr-xqpid/tests/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/qpid/tests/setup.py b/qpid/tests/setup.py
new file mode 100755
index 0000000000..c6f3142007
--- /dev/null
+++ b/qpid/tests/setup.py
@@ -0,0 +1,31 @@
+#!/usr/bin/env python
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+from distutils.core import setup
+
+setup(name="qpid-tests",
+ version="0.7",
+ author="Apache Qpid",
+ author_email="dev@qpid.apache.org",
+ packages=["qpid_tests", "qpid_tests.broker_0_10", "qpid_tests.broker_0_9",
+ "qpid_tests.broker_0_8"],
+ package_dir={"": "src/py"},
+ url="http://qpid.apache.org/",
+ license="Apache Software License",
+ description="Apache Qpid conformance tests")