summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2011-02-18 23:42:20 +0000
committerTed Ross <tross@apache.org>2011-02-18 23:42:20 +0000
commit9fba9afe5e5f9ae1ac889edf73d3560922060f37 (patch)
tree5b3ec2405331db5309e84cf3d0a8c56326b6d34c
parent9de60b44364c99806877e82dce12b8cf7497cef2 (diff)
downloadqpid-python-9fba9afe5e5f9ae1ac889edf73d3560922060f37.tar.gz
QPID-3061 - blocked qmf2 build for Windows until dependency issues are resolved.
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1072197 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/CMakeLists.txt146
1 files changed, 74 insertions, 72 deletions
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index f936c6942a..9fb133f4d0 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -1083,80 +1083,82 @@ install (TARGETS qmf OPTIONAL
COMPONENT ${QPID_COMPONENT_QMF})
install_pdb (qmf ${QPID_COMPONENT_QMF})
-set (qmf2_HEADERS
- ../include/qmf/AgentEvent.h
- ../include/qmf/Agent.h
- ../include/qmf/AgentSession.h
- ../include/qmf/ConsoleEvent.h
- ../include/qmf/ConsoleSession.h
- ../include/qmf/DataAddr.h
- ../include/qmf/Data.h
- ../include/qmf/exceptions.h
- ../include/qmf/Handle.h
- ../include/qmf/ImportExport.h
- ../include/qmf/Query.h
- ../include/qmf/Schema.h
- ../include/qmf/SchemaId.h
- ../include/qmf/SchemaMethod.h
- ../include/qmf/SchemaProperty.h
- ../include/qmf/SchemaTypes.h
- ../include/qmf/Subscription.h
- )
+if(NOT WIN32)
+ set (qmf2_HEADERS
+ ../include/qmf/AgentEvent.h
+ ../include/qmf/Agent.h
+ ../include/qmf/AgentSession.h
+ ../include/qmf/ConsoleEvent.h
+ ../include/qmf/ConsoleSession.h
+ ../include/qmf/DataAddr.h
+ ../include/qmf/Data.h
+ ../include/qmf/exceptions.h
+ ../include/qmf/Handle.h
+ ../include/qmf/ImportExport.h
+ ../include/qmf/Query.h
+ ../include/qmf/Schema.h
+ ../include/qmf/SchemaId.h
+ ../include/qmf/SchemaMethod.h
+ ../include/qmf/SchemaProperty.h
+ ../include/qmf/SchemaTypes.h
+ ../include/qmf/Subscription.h
+ )
-set (qmf2_SOURCES
- ${qmf2_HEADERS}
- qmf/agentCapability.h
- qmf/Agent.cpp
- qmf/AgentEvent.cpp
- qmf/AgentEventImpl.h
- qmf/AgentImpl.h
- qmf/AgentSession.cpp
- qmf/AgentSubscription.cpp
- qmf/AgentSubscription.h
- qmf/ConsoleEvent.cpp
- qmf/ConsoleEventImpl.h
- qmf/ConsoleSession.cpp
- qmf/ConsoleSessionImpl.h
- qmf/constants.cpp
- qmf/constants.h
- qmf/DataAddr.cpp
- qmf/DataAddrImpl.h
- qmf/Data.cpp
- qmf/DataImpl.h
- qmf/exceptions.cpp
- qmf/Expression.cpp
- qmf/Expression.h
- qmf/Hash.cpp
- qmf/Hash.h
- qmf/PrivateImplRef.h
- qmf/Query.cpp
- qmf/QueryImpl.h
- qmf/Schema.cpp
- qmf/SchemaCache.cpp
- qmf/SchemaCache.h
- qmf/SchemaId.cpp
- qmf/SchemaIdImpl.h
- qmf/SchemaImpl.h
- qmf/SchemaMethod.cpp
- qmf/SchemaMethodImpl.h
- qmf/SchemaProperty.cpp
- qmf/SchemaPropertyImpl.h
- qmf/Subscription.cpp
- qmf/SubscriptionImpl.h
- )
+ set (qmf2_SOURCES
+ ${qmf2_HEADERS}
+ qmf/agentCapability.h
+ qmf/Agent.cpp
+ qmf/AgentEvent.cpp
+ qmf/AgentEventImpl.h
+ qmf/AgentImpl.h
+ qmf/AgentSession.cpp
+ qmf/AgentSubscription.cpp
+ qmf/AgentSubscription.h
+ qmf/ConsoleEvent.cpp
+ qmf/ConsoleEventImpl.h
+ qmf/ConsoleSession.cpp
+ qmf/ConsoleSessionImpl.h
+ qmf/constants.cpp
+ qmf/constants.h
+ qmf/DataAddr.cpp
+ qmf/DataAddrImpl.h
+ qmf/Data.cpp
+ qmf/DataImpl.h
+ qmf/exceptions.cpp
+ qmf/Expression.cpp
+ qmf/Expression.h
+ qmf/Hash.cpp
+ qmf/Hash.h
+ qmf/PrivateImplRef.h
+ qmf/Query.cpp
+ qmf/QueryImpl.h
+ qmf/Schema.cpp
+ qmf/SchemaCache.cpp
+ qmf/SchemaCache.h
+ qmf/SchemaId.cpp
+ qmf/SchemaIdImpl.h
+ qmf/SchemaImpl.h
+ qmf/SchemaMethod.cpp
+ qmf/SchemaMethodImpl.h
+ qmf/SchemaProperty.cpp
+ qmf/SchemaPropertyImpl.h
+ qmf/Subscription.cpp
+ qmf/SubscriptionImpl.h
+ )
-add_msvc_version (qmf2 library dll)
-add_library (qmf2 SHARED ${qmf2_SOURCES})
-target_link_libraries (qmf2 qpidmessaging qpidtypes)
-set_target_properties (qmf2 PROPERTIES
- VERSION ${qmf2_version})
-install (TARGETS qmf2 OPTIONAL
- DESTINATION ${QPID_INSTALL_LIBDIR}
- COMPONENT ${QPID_COMPONENT_QMF})
-install (FILES ${qmf2_HEADERS}
- DESTINATION ${QPID_INSTALL_INCLUDEDIR}/qmf
- COMPONENT ${QPID_COMPONENT_QMF})
-install_pdb (qmf2 ${QPID_COMPONENT_QMF})
+ add_msvc_version (qmf2 library dll)
+ add_library (qmf2 SHARED ${qmf2_SOURCES})
+ target_link_libraries (qmf2 qpidmessaging qpidtypes qpidclient qpidcommon)
+ set_target_properties (qmf2 PROPERTIES
+ VERSION ${qmf2_version})
+ install (TARGETS qmf2 OPTIONAL
+ DESTINATION ${QPID_INSTALL_LIBDIR}
+ COMPONENT ${QPID_COMPONENT_QMF})
+ install (FILES ${qmf2_HEADERS}
+ DESTINATION ${QPID_INSTALL_INCLUDEDIR}/qmf
+ COMPONENT ${QPID_COMPONENT_QMF})
+ install_pdb (qmf2 ${QPID_COMPONENT_QMF})
+endif (NOT WIN32)
set (qmfengine_SOURCES
qmf/engine/Agent.cpp