summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2011-08-26 22:16:01 +0000
committerAlan Conway <aconway@apache.org>2011-08-26 22:16:01 +0000
commitd9e5d1733dafa6a7b7cb8c325a1ccebed96bfd88 (patch)
treeb40d59df62bba6d9a11d410974c291e7eee751f8
parent2fa119666035c81b4073b4509e7cf155f48e6771 (diff)
downloadqpid-python-d9e5d1733dafa6a7b7cb8c325a1ccebed96bfd88.tar.gz
QPID-3457: qpid::Msg::str() method not exported
Previous fix was incomplete. The class Msg is used by Variant.cpp in the types library. Moved the Msg class from common to types library. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1162273 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/include/qpid/Msg.h4
-rw-r--r--qpid/cpp/src/Makefile.am2
2 files changed, 3 insertions, 3 deletions
diff --git a/qpid/cpp/include/qpid/Msg.h b/qpid/cpp/include/qpid/Msg.h
index 5a55be28db..7a39a41c8d 100644
--- a/qpid/cpp/include/qpid/Msg.h
+++ b/qpid/cpp/include/qpid/Msg.h
@@ -24,7 +24,7 @@
#include <sstream>
#include <iostream>
-#include "qpid/CommonImportExport.h"
+#include "qpid/types/ImportExport.h"
namespace qpid {
@@ -42,7 +42,7 @@ struct Msg {
std::ostringstream os;
Msg() {}
Msg(const Msg& m) : os(m.str()) {}
- QPID_COMMON_EXTERN std::string str() const;
+ QPID_TYPES_EXTERN std::string str() const;
operator std::string() const { return str(); }
Msg& operator<<(long n) { os << n; return *this; }
diff --git a/qpid/cpp/src/Makefile.am b/qpid/cpp/src/Makefile.am
index e502000758..9171caed1e 100644
--- a/qpid/cpp/src/Makefile.am
+++ b/qpid/cpp/src/Makefile.am
@@ -435,7 +435,6 @@ libqpidcommon_la_SOURCES += \
qpid/log/OstreamOutput.h \
qpid/log/Selector.cpp \
qpid/log/Statement.cpp \
- qpid/Msg.cpp \
qpid/management/Buffer.cpp \
qpid/management/ConnectionSettings.cpp \
qpid/management/Manageable.cpp \
@@ -745,6 +744,7 @@ libqpidclient_la_LDFLAGS = -version-info $(QPIDCLIENT_VERSION_INFO)
libqpidtypes_la_LIBADD= -luuid
libqpidtypes_la_SOURCES= \
+ qpid/Msg.cpp \
qpid/types/Exception.cpp \
qpid/types/Uuid.cpp \
qpid/types/Variant.cpp \